aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firetools
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-05-10 17:44:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-20 16:00:10 +0000
commitbaecb8d02508a7697bcc80dc03c281afc78ad62c (patch)
treec5e313a9a1b1e780650cee9ca2f98d110b008bc8 /testing/firetools
parent9513b5116c59c2e82592b569d1d9dbe6abc4c1a1 (diff)
downloadaports-baecb8d02508a7697bcc80dc03c281afc78ad62c.tar.bz2
aports-baecb8d02508a7697bcc80dc03c281afc78ad62c.tar.xz
testing/firetools: new aport
firetools is a GUI / systray app for firejail
Diffstat (limited to 'testing/firetools')
-rw-r--r--testing/firetools/APKBUILD44
-rw-r--r--testing/firetools/fix-qt-configure.patch46
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/firetools/APKBUILD b/testing/firetools/APKBUILD
new file mode 100644
index 0000000000..670c137288
--- /dev/null
+++ b/testing/firetools/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=firetools
+pkgver=0.9.30
+pkgrel=0
+pkgdesc="Firejail sandbox launcher integrated with the system tray"
+url="https://l3net.wordpress.com/projects/firejail/#firetools"
+arch="all"
+license="GPL2"
+depends="firejail xterm icu-libs"
+#depends="firejail xterm" #building against qt5 requires v.5.60 which is currently in edge
+depends_dev=""
+#makedepends="$depends_dev qt5-qtbase-dev qt5-qtsvg-dev"
+makedepends="$depends_dev qt-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/netblue30/firetools/archive/$pkgver.tar.gz
+ fix-qt-configure.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="11ddf9c6645f2d218e9cc5ad20070277 firetools-0.9.30.tar.gz
+2f8c60628d3155c30d988a8b5745916a fix-qt-configure.patch"
+sha256sums="b54e3ae5f619a4e77f9a0044b791ea0cc86ccaf9ad07014898222bc8ae0bd56d firetools-0.9.30.tar.gz
+9788d0b5c3738fe12b41cd9040f1c8b9a3718e57809d76c12b67ff79b818f4e7 fix-qt-configure.patch"
+sha512sums="237e1dc0b091874f34a326cca799a9b515861ff8966e319c6b79a6cd717f74d38d39fbd1cbbdaa85563cbfd3eddf61c204d1acf4caf9923c020638080225b199 firetools-0.9.30.tar.gz
+3a732d6fbd7e93b9bbd0cdf6484aff339069304333a319273e43d3147a32476d0812a7779187a5874a9d59f2f6bf5307fc2b93acf39f631e68f9d9eb8eddb5b5 fix-qt-configure.patch"
diff --git a/testing/firetools/fix-qt-configure.patch b/testing/firetools/fix-qt-configure.patch
new file mode 100644
index 0000000000..c0db8c9dda
--- /dev/null
+++ b/testing/firetools/fix-qt-configure.patch
@@ -0,0 +1,46 @@
+--- firetools-0.9.30/configure
++++ firetools-0.9.30/configure.new
+@@ -3811,18 +3811,24 @@
+ as_fn_error $? "*** Please install Qt5 svg support - apt-get install libqt5svg5 ***" "$LINENO" 5
+ fi
+
+-# Arch Linux 64bit
++# Arch Linux 64bit & Alpine Linux
+ elif test -f /usr/lib/libQt5Core.so
+ then
++ if test -d /usr/lib/qt5
++ then
++ qtdir='qt5'
++ else
++ qtdir='qt'
++ fi
+ echo "Found qt5 library in /usr/lib directory"
+ # check libqt5svg5 library
+- if test -f /usr/lib/qt/plugins/imageformats/libqsvg.so
++ if test -f /usr/lib/$qtdir/plugins/imageformats/libqsvg.so
+ then
+ echo "Found qt5 svg library"
+ else
+ as_fn_error $? "*** Please install Qt5 svg support - pacman -S qt5-svg ***" "$LINENO" 5
+ fi
+- if test -f /usr/lib/qt/plugins/iconengines/libqsvgicon.so
++ if test -f /usr/lib/$qtdir/plugins/iconengines/libqsvgicon.so
+ then
+ echo "Found qt5 svg icon library"
+ else
+
+--- firetools-0.9.30/configure
++++ firetools-0.9.30/configure.new
+@@ -3939,6 +3939,11 @@
+ QMAKE=/usr/lib64/qt4/bin/qmake
+ fi
+
++ # fix for Alpine Linux
++ if test -f /usr/lib/qt5/bin/qmake; then
++ QMAKE=/usr/lib/qt5/bin/qmake
++ fi
++
+ if test -z "$QMAKE"
+ then
+ as_fn_error $? "qmake is missing, please install Qt4 or Qt5 development packages." "$LINENO" 5
+