aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fltk
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
commite7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc (patch)
treec6b816e7ba8f9b659e1be415ebf1dac4262c3b82 /testing/fltk
parent452d447d89b3a3775b7f602d7352a8cfe8a0f9d4 (diff)
downloadaports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.bz2
aports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.xz
testing/*: move to main
Diffstat (limited to 'testing/fltk')
-rw-r--r--testing/fltk/APKBUILD63
-rw-r--r--testing/fltk/ewmh-crash.patch23
2 files changed, 0 insertions, 86 deletions
diff --git a/testing/fltk/APKBUILD b/testing/fltk/APKBUILD
deleted file mode 100644
index fa0192c856..0000000000
--- a/testing/fltk/APKBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# Contributor: ScrumpyJack <scrumpyjack@me.com>
-# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=fltk
-pkgver=1.3.3
-pkgrel=0
-pkgdesc="A cross-platform C++ GUI toolkit"
-url="http://fltk.org"
-arch="all"
-license="GPL"
-depends=""
-depends_dev="libx11-dev libxext-dev libxft-dev"
-makedepends="$depends_dev libpng-dev libjpeg-turbo-dev"
-install=""
-subpackages="$pkgname-doc $pkgname-dev $pkgname-fluid"
-source="http://fltk.org/pub/fltk/$pkgver/$pkgname-$pkgver-source.tar.gz
- ewmh-crash.patch"
-
-_builddir=$srcdir/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-shared \
- --enable-threads \
- --with-optim="$CXXFLAGS" \
- || return 1
- make V=1 || return 1
-
-}
-
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- # remove static libs
- rm "$pkgdir"/usr/lib/*.a || return 1
-}
-
-fluid() {
- pkgdesc="Fast Light User Interface Designer"
- depends=
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-md5sums="9ccdb0d19dc104b87179bd9fd10822e3 fltk-1.3.3-source.tar.gz
-0b1a9c825de9de368550d10728878019 ewmh-crash.patch"
-sha256sums="f8398d98d7221d40e77bc7b19e761adaf2f1ef8bb0c30eceb7beb4f2273d0d97 fltk-1.3.3-source.tar.gz
-15adf29c8d2885bc356943f05b3f22b2db42a5278a9a27d8b1bd3f342f3f4416 ewmh-crash.patch"
-sha512sums="277ba27e35c20e2d4fc5296bf418c5ab78c821870476e21d49f723765b99b3a559eed4ecd5215ac26d53a1091ada003e17f1553194cebaa97dd854809dd2885d fltk-1.3.3-source.tar.gz
-7e7c43620c91f83da190227d829ebe652ccf1e02ad40e6b3d2631959716304612f447f2dffba0f19fc2c5191692e23581c438945f61669f4974845a1ac1e9929 ewmh-crash.patch"
diff --git a/testing/fltk/ewmh-crash.patch b/testing/fltk/ewmh-crash.patch
deleted file mode 100644
index 6b7d08e1bb..0000000000
--- a/testing/fltk/ewmh-crash.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit 6bea02745202d86a10da82d34f1f6a9233267297
-Author: lauri <cand.svn@fltk.example.org>
-Date: Tue Nov 4 17:26:47 2014 +0000
-
- The EWMH check requires an open display.
-
- Fixes a crash when a program calls take_focus() before any window has been show()n.
-
-
- git-svn-id: http://seriss.com/public/fltk/fltk/branches/branch-1.3@10434 ea41ed52-d2ee-0310-a9c1-e6b18d33e121
-
-diff --git a/src/Fl_x.cxx b/src/Fl_x.cxx
-index 8e7100b..a0767a3 100644
---- a/src/Fl_x.cxx
-+++ b/src/Fl_x.cxx
-@@ -2211,6 +2211,7 @@ int Fl_X::ewmh_supported() {
- static int result = -1;
-
- if (result == -1) {
-+ fl_open_display();
- result = 0;
- unsigned long nitems;
- unsigned long *words = 0;