aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fontforge
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-04 10:02:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:35:33 +0000
commitf45e09feb2378283c5d91bdc8afed47f868c5f15 (patch)
tree3971d1f51e70288fa1e69678323edda68cf14ea1 /testing/fontforge
parentfbfbc57cc09a5e2dfe29cdffc9460eb3eb39caa6 (diff)
downloadaports-f45e09feb2378283c5d91bdc8afed47f868c5f15.tar.bz2
aports-f45e09feb2378283c5d91bdc8afed47f868c5f15.tar.xz
testing/fontforge: rebuild against python 3.8
Diffstat (limited to 'testing/fontforge')
-rw-r--r--testing/fontforge/APKBUILD11
-rw-r--r--testing/fontforge/python-3.8.patch13
2 files changed, 23 insertions, 1 deletions
diff --git a/testing/fontforge/APKBUILD b/testing/fontforge/APKBUILD
index 1767f5394b..54bd02c05b 100644
--- a/testing/fontforge/APKBUILD
+++ b/testing/fontforge/APKBUILD
@@ -8,6 +8,8 @@ url="https://github.com/fontforge/fontforge"
arch="all !s390x"
license="GPL-3.0-or-later"
makedepends="
+ autoconf
+ automake
libtool
pango-dev
giflib-dev
@@ -28,8 +30,14 @@ subpackages="
"
source="https://github.com/fontforge/fontforge/releases/download/$pkgver/fontforge-$pkgver.tar.gz
fix-select.patch
+ python-3.8.patch
"
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
./configure \
--prefix=/usr \
@@ -59,4 +67,5 @@ _py3() {
}
sha512sums="78f3e1e94e38e26dcf52c6a0e038753033dc47052b7492f0ac0aaf1b8962e4e4bbf07c2550ef6014ea7290a6429bf669acb0691735efe0aee368480b4b7e6236 fontforge-20190801.tar.gz
-8cb3fb00fa537eab2d4b194916343a0e2aab85c2415a1944c0d0e648d62a7748d5d4465fb99cb92385b749e73abfcaa429f4c9d2bb4c2edea8febeb227add93a fix-select.patch"
+8cb3fb00fa537eab2d4b194916343a0e2aab85c2415a1944c0d0e648d62a7748d5d4465fb99cb92385b749e73abfcaa429f4c9d2bb4c2edea8febeb227add93a fix-select.patch
+a7b2775131845b35227d465421d2b3e472b92f1c682462d7860aa6fead80f0e9949123e0c97ff819b3ab2223915e6fd50157bc799ccd48f1c8a1973c338e2bfa python-3.8.patch"
diff --git a/testing/fontforge/python-3.8.patch b/testing/fontforge/python-3.8.patch
new file mode 100644
index 0000000000..7fd172a338
--- /dev/null
+++ b/testing/fontforge/python-3.8.patch
@@ -0,0 +1,13 @@
+diff --git a/m4/fontforge_arg_enable.m4 b/m4/fontforge_arg_enable.m4
+index 6f1177c..584261c 100644
+--- a/m4/fontforge_arg_enable.m4
++++ b/m4/fontforge_arg_enable.m4
+@@ -116,7 +116,7 @@ fi
+ if test x"${i_do_have_python_scripting}" != xyes; then
+ i_want_python_ver=
+ else
+- PKG_CHECK_MODULES([PYTHON],[python-"${PYTHON_VERSION}"], dnl [PKG_CHECK_MODULES([PYTHONDEV],[python-"${PYTHON_VERSION}"],,[i_do_have_python_scripting=maybe])],
++ PKG_CHECK_MODULES([PYTHON],[python-"${PYTHON_VERSION}"-embed], dnl [PKG_CHECK_MODULES([PYTHONDEV],[python-"${PYTHON_VERSION}"],,[i_do_have_python_scripting=maybe])],
+ [PKG_CHECK_MODULES([PYTHONDEV],[python-"${PYTHON_VERSION}"],,[i_do_have_python_scripting=no])],
+ [i_do_have_python_scripting=no])
+ dnl dnl TODO: have python3 AND python2, but only have python2 dev, but no python3 dev