aboutsummaryrefslogtreecommitdiffstats
path: root/testing/foremost
diff options
context:
space:
mode:
authorJesse Young <jlyo@jlyo.org>2015-09-15 09:09:21 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-16 16:21:55 +0200
commitb3c7b651383f33fbb8a7d73dc1832732ce75ac2b (patch)
treef687fb7d4e9ec554ad5fdd7ef37a73c6d0b3a1d2 /testing/foremost
parenta8e2692e5766f2e656f087e53c6b32a7c5aef3a9 (diff)
downloadaports-b3c7b651383f33fbb8a7d73dc1832732ce75ac2b.tar.bz2
aports-b3c7b651383f33fbb8a7d73dc1832732ce75ac2b.tar.xz
testing/foremost: new aport
Diffstat (limited to 'testing/foremost')
-rw-r--r--testing/foremost/APKBUILD49
-rw-r--r--testing/foremost/foremost-makefile.patch23
2 files changed, 72 insertions, 0 deletions
diff --git a/testing/foremost/APKBUILD b/testing/foremost/APKBUILD
new file mode 100644
index 0000000000..16170a0d10
--- /dev/null
+++ b/testing/foremost/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Jesse Young <jlyo@jlyo.org>
+# Maintainer: Jesse Young <jlyo@jlyo.org>
+
+pkgname=foremost
+pkgver=1.5.7
+pkgrel=0
+pkgdesc="A console program to recover files based on their headers, footers, and internal data structures"
+url="http://foremost.sourceforge.net/"
+arch="all"
+license="custom"
+depends_dev=""
+depends=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://foremost.sourceforge.net/pkg/${pkgname}-${pkgver}.tar.gz \
+ ${pkgname}-makefile.patch"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package () {
+ cd "$_builddir"
+ for f in etc usr/bin usr/share/man/man8 usr/share/licenses/foremost; do
+ install -dm755 "${pkgdir}/${f}"
+ done
+ make DESTDIR="$pkgdir" install
+ ./foremost -V > "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+}
+
+md5sums="860119c49665c2a3fb2b0b1d3dbad02a foremost-1.5.7.tar.gz
+e78b7e14ef18a7941bb558af00f3b294 foremost-makefile.patch"
+sha256sums="502054ef212e3d90b292e99c7f7ac91f89f024720cd5a7e7680c3d1901ef5f34 foremost-1.5.7.tar.gz
+80592050c42571b7254a7e166d56b9761a6c72050406dc8adf35aff934bd242a foremost-makefile.patch"
+sha512sums="8827c29d52496783be26374f3943eb26a154d842f34e50fb489f87b3a5045bf85f1e44d7d8d8b12b2355ba3fe4b06a0db979cc22c0f431593c5976001eb931ab foremost-1.5.7.tar.gz
+22c28169e19c3fedb1f9ad470a6218ce63091f813257a222bda66d2ae04933e2694bc17ba4635b75db94f5375485ac0d5c1583c175b4d1674a9ff58c29967caa foremost-makefile.patch"
diff --git a/testing/foremost/foremost-makefile.patch b/testing/foremost/foremost-makefile.patch
new file mode 100644
index 0000000000..445471e011
--- /dev/null
+++ b/testing/foremost/foremost-makefile.patch
@@ -0,0 +1,23 @@
+--- a/Makefile 2008-10-14 02:09:13.000000000 +0200
++++ b/Makefile 2008-10-14 18:31:38.000000000 +0200
+@@ -26,5 +26,5 @@
+ # Where we get installed
+-BIN = /usr/local/bin
+-MAN = /usr/share/man/man8
+-CONF= /usr/local/etc
++BIN = $(DESTDIR)/usr/bin
++MAN = $(DESTDIR)/usr/share/man/man8
++CONF= $(DESTDIR)/etc
+ # Setup for compiling and cross-compiling for Windows
+diff -uNr foremost-1.4.orig/config.c foremost-1.4/config.c
+--- a/config.c 2006-08-31 17:50:47.000000000 +0100
++++ b/config.c 2006-08-31 17:51:09.000000000 +0100
+@@ -288,7 +288,7 @@
+ #ifdef __WIN32
+ set_config_file(s, "/Program Files/foremost/foremost.conf");
+ #else
+- set_config_file(s, "/usr/local/etc/foremost.conf");
++ set_config_file(s, "/etc/foremost.conf");
+ #endif
+ if ((f = fopen(get_config_file(s), "r")) == NULL)
+ {