aboutsummaryrefslogtreecommitdiffstats
path: root/testing/frameworkintegration
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-31 21:33:42 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 18:56:03 +0000
commitcec6e8a29710e764bba747936b952ead2e437acf (patch)
tree140e312ccee0e2be138315104785f15094ae8acf /testing/frameworkintegration
parent49f7b7bbff3084ac325fe4613c14a991f94293d0 (diff)
downloadaports-cec6e8a29710e764bba747936b952ead2e437acf.tar.bz2
aports-cec6e8a29710e764bba747936b952ead2e437acf.tar.xz
testing/frameworkintegration: new aport
Closes GH-8333
Diffstat (limited to 'testing/frameworkintegration')
-rw-r--r--testing/frameworkintegration/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/frameworkintegration/APKBUILD b/testing/frameworkintegration/APKBUILD
new file mode 100644
index 0000000000..630be0580f
--- /dev/null
+++ b/testing/frameworkintegration/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=frameworkintegration
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
+arch="all"
+url="https://www.kde.org"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev"
+options="!check" # Requires X11 running
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="80f2d8c3dcaa57632bab12ca581ae57665b6bbea9f68aa439cf91f8bb7e987954a0b6787bc7f73e6e5cc8f605b28162a654bce6fa2aa3f699fc909fd5f0f5794 frameworkintegration-5.58.0.tar.xz"