aboutsummaryrefslogtreecommitdiffstats
path: root/testing/freeimage/0005-makefile-gnu.patch
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-03-13 16:11:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-15 12:17:13 +0000
commitad5f1c6d0271a309ce8e3e8db40f80dd8f6d9589 (patch)
treec693232d17cdc42eec6d64ebb8bd8e146f950f2b /testing/freeimage/0005-makefile-gnu.patch
parentee975cb257a94a9a48a4785d6e68e00d46929b06 (diff)
downloadaports-ad5f1c6d0271a309ce8e3e8db40f80dd8f6d9589.tar.bz2
aports-ad5f1c6d0271a309ce8e3e8db40f80dd8f6d9589.tar.xz
testing/freeimage: make sure fPIC CFLAGs picked up in Makefile.gnu
Diffstat (limited to 'testing/freeimage/0005-makefile-gnu.patch')
-rw-r--r--testing/freeimage/0005-makefile-gnu.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/freeimage/0005-makefile-gnu.patch b/testing/freeimage/0005-makefile-gnu.patch
new file mode 100644
index 0000000000..f70a22aac8
--- /dev/null
+++ b/testing/freeimage/0005-makefile-gnu.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile.gnu b/Makefile.gnu
+index 92f6358..293ee97 100644
+--- a/Makefile.gnu
++++ b/Makefile.gnu
+@@ -15,7 +15,8 @@ LIBRARIES = -lstdc++
+
+ MODULES = $(SRCS:.c=.o)
+ MODULES := $(MODULES:.cpp=.o)
+-CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
++CFLAGS ?= -O3
++CFLAGS += -fPIC -fexceptions -fvisibility=hidden
+ # OpenJPEG
+ CFLAGS += -DOPJ_STATIC
+ # LibRaw
+@@ -23,7 +24,8 @@ CFLAGS += -DNO_LCMS
+ # LibJXR
+ CFLAGS += -DDISABLE_PERF_MEASUREMENT -D__ANSI__
+ CFLAGS += $(INCLUDE)
+-CXXFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
++CXXFLAGS ?= -O3
++CXXFLAGS += -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
+ # LibJXR
+ CXXFLAGS += -D__ANSI__
+ CXXFLAGS += $(INCLUDE)