aboutsummaryrefslogtreecommitdiffstats
path: root/testing/frr/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 12:05:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 12:37:48 -0300
commit43cac210ee9ac7a736b07e3f6b7162be1674d554 (patch)
tree2a78265df76b32c2a10e6e8e5542498b7a9bcf92 /testing/frr/APKBUILD
parent35c6452a338f6a7f1bfb9896cf43594b80eaf8c8 (diff)
downloadaports-43cac210ee9ac7a736b07e3f6b7162be1674d554.tar.bz2
aports-43cac210ee9ac7a736b07e3f6b7162be1674d554.tar.xz
testing/frr: use python3
Diffstat (limited to 'testing/frr/APKBUILD')
-rw-r--r--testing/frr/APKBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/testing/frr/APKBUILD b/testing/frr/APKBUILD
index 9fa810862a..1ed1f67a44 100644
--- a/testing/frr/APKBUILD
+++ b/testing/frr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Franke <nobody@nowhere.ws>
pkgname=frr
pkgver=7.1
-pkgrel=0
+pkgrel=1
pkgdesc="Free Range Routing is a fork of Quagga"
pkgusers="frr"
pkggroups="frr frrvty"
@@ -17,13 +17,13 @@ makedepends="autoconf automake libtool
libyang-dev
linux-headers
net-snmp-dev
- py-sphinx
+ py3-sphinx
python3-dev
readline-dev
rtrlib-dev
texinfo
"
-checkdepends="pytest py-setuptools"
+checkdepends="py3-pytest"
install="$pkgname.pre-install"
subpackages="$pkgname-dbg
$pkgname-doc::noarch
@@ -32,15 +32,22 @@ subpackages="$pkgname-dbg
$pkgname-rpki
$pkgname-snmp
"
-source="https://github.com/FRRouting/frr/archive/$pkgname-$pkgver.tar.gz
- frr.initd"
+source="https://github.com/FRRouting/frr/archive/frr-$pkgver.tar.gz
+ frr.initd
+ py3.patch
+ "
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
_sysconfdir=/etc/frr
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
./bootstrap.sh
+}
+
+build() {
+ export PYTHON=python3
+
./configure \
--prefix=/usr \
--enable-exampledir=/usr/share/doc/frr/examples/ \
@@ -67,17 +74,17 @@ build() {
--enable-group=${pkggroups%% *} \
--enable-vty-group=frrvty \
--enable-configfile-mask=0640 \
- --enable-logfile-mask=0640
+ --enable-logfile-mask=0640 \
+ SPHINXBUILD=sphinx-build-3
make
}
check() {
- cd "$builddir"
+ export PYTHON=python3
make -j 1 check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# Remove development files, static libraries and headers.
@@ -100,7 +107,7 @@ package() {
pythontools() {
pkgdesc="$pkgdesc (tools)"
- depends="python2 py2-ipaddr"
+ depends="python3 py3-ipaddr"
mkdir -p "$subpkgdir"/usr/lib/frr
mv "$pkgdir"/usr/lib/frr/frr-reload.py "$subpkgdir/usr/lib/frr"
}
@@ -119,4 +126,5 @@ snmp() {
}
sha512sums="d1020607c4c142cc2895c514dcee232a6711a01e63e35a4005249fba9a2b491ebede6dfcfc8d1e885d9d93aff34c99aaced987141040f437eba6779007d06817 frr-7.1.tar.gz
-b495b2be9f2cbb065104ccc0c3474471e870b53ac62ed4fba40020c8d50866e637a99ef3d7af5de1018ff659c4757baac4f40d7648a9de99ed14db33c8992b54 frr.initd"
+b495b2be9f2cbb065104ccc0c3474471e870b53ac62ed4fba40020c8d50866e637a99ef3d7af5de1018ff659c4757baac4f40d7648a9de99ed14db33c8992b54 frr.initd
+56153758bb543229e54343f15abdb18661317d42f2d244300c298a8ea5b6cd21d573a7379d184541f9c6110028c2049d9911849a14ae3febcc299e5a5050b2ae py3.patch"