aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fuse-exfat
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-27 15:10:01 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-27 15:10:29 +0100
commitbb6fdadbb05d552fe1c81e87925e829933d53622 (patch)
tree57846b3e332c702a1ab6748a2f3cbfff40ac616c /testing/fuse-exfat
parent2a143e1c24b4946ed158a9b8884273cb500d7677 (diff)
downloadaports-bb6fdadbb05d552fe1c81e87925e829933d53622.tar.bz2
aports-bb6fdadbb05d552fe1c81e87925e829933d53622.tar.xz
testing/fuse-extfat: upgrade to 1.1.0 and fix musl build
Diffstat (limited to 'testing/fuse-exfat')
-rw-r--r--testing/fuse-exfat/APKBUILD16
-rw-r--r--testing/fuse-exfat/musl-not-found.patch18
2 files changed, 28 insertions, 6 deletions
diff --git a/testing/fuse-exfat/APKBUILD b/testing/fuse-exfat/APKBUILD
index 3c4dd60ae3..02eb518289 100644
--- a/testing/fuse-exfat/APKBUILD
+++ b/testing/fuse-exfat/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse-exfat
-pkgver=1.0.1
-pkgrel=1
+pkgver=1.1.0
+pkgrel=0
pkgdesc="Free exFAT file system implementation"
url="http://code.google.com/p/exfat/"
arch="all"
@@ -11,7 +11,8 @@ depends_dev=""
makedepends="$depends_dev fuse-dev scons"
install=""
subpackages=""
-source="http://exfat.googlecode.com/files/fuse-exfat-$pkgver.tar.gz"
+source="http://pkgbuild.com/~giovanni/exfat/${pkgname}-${pkgver}.tar.gz
+ musl-not-found.patch"
_builddir="$srcdir"/fuse-exfat-$pkgver
prepare() {
@@ -36,6 +37,9 @@ package() {
scons DESTDIR="$pkgdir"/sbin install || return 1
}
-md5sums="7988a5111841593231f20af22153362d fuse-exfat-1.0.1.tar.gz"
-sha256sums="12ac1ba1b7d4343bef64e7898176705a41cfe3b5a7a179e28549d242e2854758 fuse-exfat-1.0.1.tar.gz"
-sha512sums="e444031e7a6b999b3014ced255447bdfe4586b16970f36393706433262ca0cbd17911d6ca7af3465871f3136bdd9c8be2ec85f0dd124d670b240829093d341f6 fuse-exfat-1.0.1.tar.gz"
+md5sums="b2a23c032661cb1c1da4514e7af33916 fuse-exfat-1.1.0.tar.gz
+627d23007699396bb85e0da9efbcc8bd musl-not-found.patch"
+sha256sums="198c520e417e955dc5c08687c278e63eefa56719da4452aa4a605be0327f953e fuse-exfat-1.1.0.tar.gz
+e456763cc9d05b87efd331ca8480f28c6aac38d1a89fab37bb9a0313b89254ae musl-not-found.patch"
+sha512sums="60280687c9adea3955fd85f003482e9d40163924837e5dcac4205c2bd02318c8ea280103a509213e83a04d390507f15dfe3cd3ecc03e9b90abcf4cef7e830398 fuse-exfat-1.1.0.tar.gz
+55a662908230516e30085da361ed6f4d2f2f8eac60e99b8399fa5bb343eeeae28d84ec363b8be603f08063d6a4b7e4e3503ebf37cfa958e8d6dcba84eedbe7b6 musl-not-found.patch"
diff --git a/testing/fuse-exfat/musl-not-found.patch b/testing/fuse-exfat/musl-not-found.patch
new file mode 100644
index 0000000000..9d032e4953
--- /dev/null
+++ b/testing/fuse-exfat/musl-not-found.patch
@@ -0,0 +1,18 @@
+--- a/libexfat/platform.h.orig
++++ b/libexfat/platform.h
+@@ -57,7 +57,14 @@
+ #define EXFAT_BIG_ENDIAN _BIG_ENDIAN
+
+ #else
+-#error Unknown platform
++#include <endian.h>
++#include <byteswap.h>
++#define exfat_bswap16(x) bswap_16(x)
++#define exfat_bswap32(x) bswap_32(x)
++#define exfat_bswap64(x) bswap_64(x)
++#define EXFAT_BYTE_ORDER __BYTE_ORDER
++#define EXFAT_LITTLE_ENDIAN __LITTLE_ENDIAN
++#define EXFAT_BIG_ENDIAN __BIG_ENDIAN
+ #endif
+
+ #endif /* ifndef PLATFORM_H_INCLUDED */