aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gb
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 00:50:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 00:50:57 -0300
commitf266f1ae41e52550c12649bdf59383e884cb7097 (patch)
tree3c76ee435c4debacef6d283774073c71af2889b7 /testing/gb
parent0d071d359ee82e68c5098324ce563e53dd3d6917 (diff)
downloadaports-f266f1ae41e52550c12649bdf59383e884cb7097.tar.bz2
aports-f266f1ae41e52550c12649bdf59383e884cb7097.tar.xz
testing/gb: fix url disable check
Diffstat (limited to 'testing/gb')
-rw-r--r--testing/gb/APKBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/testing/gb/APKBUILD b/testing/gb/APKBUILD
index 1109e53bec..fcbfc6e748 100644
--- a/testing/gb/APKBUILD
+++ b/testing/gb/APKBUILD
@@ -3,15 +3,13 @@
pkgname=gb
pkgver=0.4.4
_errors_ver=0.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="Project based build tool for Go"
-url="https://getgb.io/"
+options="!check"
+url="https://github.com/constabulary/gb"
arch="all"
license="MIT"
-depends=""
makedepends="go"
-install=""
-subpackages=""
source="gb-$pkgver.tar.gz::https://github.com/constabulary/gb/archive/v$pkgver.tar.gz
go-errors-$_errors_ver.tar.gz::https://github.com/pkg/errors/archive/v$_errors_ver.tar.gz
buildmode-pie.patch
@@ -19,31 +17,21 @@ source="gb-$pkgver.tar.gz::https://github.com/constabulary/gb/archive/v$pkgver.t
builddir="$srcdir/src/github.com/constabulary/$pkgname"
prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
mkdir -p "$srcdir"/src/github.com/pkg
mv "$srcdir"/errors-$_errors_ver "$srcdir"/src/github.com/pkg/errors
- cd "$builddir"
- default_prepare
+ default_prepare
}
build() {
- cd "$builddir"
- export GOPATH="$srcdir"
+ export GOPATH="$srcdir"
for bin in gb gb-vendor; do
cd "$builddir"/cmd/$bin && go build -v
done
}
-check() {
- msg "Running tests..."
- for bin in gb gb-vendor; do
- "$builddir"/cmd/$bin/$bin help > /dev/null
- done
-}
-
package() {
- cd "$builddir"
for bin in gb gb-vendor; do
install -Dm755 "$builddir"/cmd/$bin/$bin \
"$pkgdir"/usr/bin/$bin