aboutsummaryrefslogtreecommitdiffstats
path: root/testing/geos/APKBUILD
diff options
context:
space:
mode:
authorEric Kidd <git@randomhacks.net>2016-04-19 12:58:54 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-20 10:15:53 +0000
commit36336f64b642ce503402c0108707cfd74559f6f4 (patch)
treefc21dcf9cd530a50a6e020059b3e609c21612f67 /testing/geos/APKBUILD
parentf84909fce532ec3cb00314783764eb94cc3afe78 (diff)
downloadaports-36336f64b642ce503402c0108707cfd74559f6f4.tar.bz2
aports-36336f64b642ce503402c0108707cfd74559f6f4.tar.xz
testing/geos: new aport
http://trac.osgeo.org/geos/ GEOS is a library providing OpenGIS and JTS spatial operations in C++.
Diffstat (limited to 'testing/geos/APKBUILD')
-rw-r--r--testing/geos/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
new file mode 100644
index 0000000000..238f715ce1
--- /dev/null
+++ b/testing/geos/APKBUILD
@@ -0,0 +1,67 @@
+# Contributor: Eric Kidd <git@randomhacks.net>
+# Maintainer:
+pkgname=geos
+pkgver=3.5.0
+pkgrel=0
+pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
+url="http://trac.osgeo.org/geos/"
+arch="all"
+license="LGPL2.1"
+depends=""
+depends_dev=""
+makedepends="swig python-dev $depends_dev"
+install=""
+subpackages="py-$pkgname:py $pkgname-dev"
+source="http://download.osgeo.org/geos/geos-$pkgver.tar.bz2 10-isnan.patch"
+
+builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i}"
+ patch -p1 -i $i || return 1
+ done
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-python \
+ || return 1
+
+ # --enable-ruby produces a gem which crashes, and which seems to
+ # mostly ignored in favor of the rgeo and ffi-geos modules, anyway.
+
+ make || return 1
+
+ # This is a complex library that does lots of complicated numeric
+ # stuff, and the unit tests are fast, so let's run them just to be
+ # safe.
+ make check || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+py() {
+ cd "$builddir"
+ pkgdesc="$pkgname Python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="136842690be7f504fba46b3c539438dd geos-3.5.0.tar.bz2
+05cb0ecb132c4d20b5444a7ec926d68c 10-isnan.patch"
+sha256sums="49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02 geos-3.5.0.tar.bz2
+1bce38b84d5ba67bc0f4725cc13d69b89654b3cd37e4189090691e8abe008040 10-isnan.patch"
+sha512sums="cd9c008c19213eb90959f950b03958e6abd9c22d83e6eb5f5a9020263ad8b0045dd5c5af60417c548fc130a57756ae1ef706710086cc277498b9ba6a0a6256b7 geos-3.5.0.tar.bz2
+3bb8a11e56f9f03138e46b96c31c57f7f080a7115d5d64a3d84c1dbd077ab61e32e7c8b441d5d167ba0f9b87ac6b978291b507ab0ef7d9f27f3fb282766a3db6 10-isnan.patch"