aboutsummaryrefslogtreecommitdiffstats
path: root/testing/geos
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-06-02 22:09:52 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-05 15:57:40 -0300
commit69c69a7f621497266a94ce4ec697be9bc7a0640e (patch)
treec8b4c0fff2af6e73f04dda3c5526d89ffe3bfad5 /testing/geos
parentb35cfaf725e86bda994fada02b713aa190b5fed1 (diff)
downloadaports-69c69a7f621497266a94ce4ec697be9bc7a0640e.tar.bz2
aports-69c69a7f621497266a94ce4ec697be9bc7a0640e.tar.xz
testing/geos: upgrade to 3.7.2
new maintainer enable on all arches switch to python3 add ruby bindings
Diffstat (limited to 'testing/geos')
-rw-r--r--testing/geos/10-configure-python3.patch35
-rw-r--r--testing/geos/APKBUILD61
2 files changed, 71 insertions, 25 deletions
diff --git a/testing/geos/10-configure-python3.patch b/testing/geos/10-configure-python3.patch
new file mode 100644
index 0000000000..417d13d492
--- /dev/null
+++ b/testing/geos/10-configure-python3.patch
@@ -0,0 +1,35 @@
+Author: Holger Jaekel <holger.jaekel@gmx.de>
+Summary: Patch configure script for python3
+----
+
+--- a/configure
++++ b/configure
+@@ -19209,8 +19209,9 @@ $as_echo "$python_path" >&6; }
+ # Check for Python library path
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python library path" >&5
+ $as_echo_n "checking for Python library path... " >&6; }
++ PYTHON_MAJOR=`echo $PYTHON_VERSION | cut -d. -f1`
+ for i in "$base_python_path/lib/python$PYTHON_VERSION/config/" "$base_python_path/lib/python$PYTHON_VERSION/" "$base_python_path/lib/python/config/" "$base_python_path/lib/python/" "$base_python_path/" "$base_python_path/libs/" ; do
+- python_path=`find $i -name libpython$PYTHON_VERSION.* -print 2> /dev/null | sed "1q"`
++ python_path=`find $i -name libpython$PYTHON_MAJOR.* -print 2> /dev/null | sed "1q"`
+ if test -n "$python_path" ; then
+ break
+ fi
+@@ -19221,7 +19222,7 @@ $as_echo "$python_path" >&6; }
+ if test -z "$python_path" ; then
+ as_fn_error $? "cannot find Python library path" "$LINENO" 5
+ fi
+- PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_VERSION"
++ PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_MAJOR"
+
+ #
+ python_site=`echo $base_python_path | sed "s/config/site-packages/"`
+@@ -19234,7 +19235,7 @@ $as_echo "$python_path" >&6; }
+ $as_echo_n "checking python extra libraries... " >&6; }
+ PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
+ conf = distutils.sysconfig.get_config_var; \
+- print (conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or '')"
++ print ((conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or ''))"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHON_EXTRA_LIBS" >&5
+ $as_echo "$PYTHON_EXTRA_LIBS" >&6; }`
+
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
index 5c7c09771f..e3f5f9dca9 100644
--- a/testing/geos/APKBUILD
+++ b/testing/geos/APKBUILD
@@ -1,21 +1,32 @@
# Contributor: Eric Kidd <git@randomhacks.net>
-# Maintainer:
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=geos
-pkgver=3.7.1
+pkgver=3.7.2
pkgrel=0
pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
url="https://trac.osgeo.org/geos/"
-# test fails on other archs
-arch="x86 x86_64"
-license="LGPL-2.1"
-makedepends="swig python2-dev"
-subpackages="py-$pkgname:py $pkgname-dev"
-source="http://download.osgeo.org/geos/geos-$pkgver.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ swig
+ python3-dev
+ ruby-dev
+ "
+subpackages="
+ py3-$pkgname:py3
+ ruby-$pkgname:ruby
+ $pkgname-dev
+ "
+source="
+ http://download.osgeo.org/geos/geos-$pkgver.tar.bz2
+ 10-configure-python3.patch
+ "
build() {
- cd "$builddir"
-
+ local CXXFLAGS=
+ case "$CARCH" in
+ aarch64*) CXXFLAGS=-ffp-contract=off ;;
+ esac
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,33 +34,33 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --enable-python
-
- # --enable-ruby produces a gem which crashes, and which seems to
- # mostly ignored in favor of the rgeo and ffi-geos modules, anyway.
-
+ --enable-python \
+ --enable-ruby
make
}
check() {
- cd "$builddir"
-
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ find $pkgdir -name "*.a" -type f -delete
}
-py() {
- pkgdesc="$pkgname Python bindings"
+py3() {
+ pkgdesc="$pkgname Python3 bindings"
- cd "$builddir"
install -d "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="01e8087bcd3cb8f873adb7b56910e1575ccb3336badfdd3f13bc6792095b7010e5ab109ea0d0cd3d1459e2e526e83bcf64d6ee3f7eb47be75639becdaacd2a87 geos-3.7.1.tar.bz2"
+ruby() {
+ pkgdesc="$pkgname Ruby bindings"
+
+ install -d "$subpkgdir"/usr/lib/ruby/vendor_ruby
+ mv "$pkgdir"/usr/local/lib/site_ruby/* "$subpkgdir"/usr/lib/ruby/vendor_ruby
+ rm -rf "$pkgdir"/usr/local
+}
+sha512sums="ff0fde2e21ed9d2770c139aa50c6efd22d9cff3c6bfd8f1ef86b064efd1ad318b08dec66e34661bc1c7a341b0837978853494f27d63988be865a8ee4f7611d38 geos-3.7.2.tar.bz2
+a76aceadb30c6a078ef9c671d8335647bd6b94094bd4bdda5958f0d50271552e8f1f7b4e9d4295986f4371a446071c3cc3a446ef520543e820bde83833fea18e 10-configure-python3.patch"