aboutsummaryrefslogtreecommitdiffstats
path: root/testing/getmail
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-04-03 09:12:01 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 07:28:33 +0000
commitd2cb215b890e89603f9a58c3cab041466fd1b8f4 (patch)
tree7d32db9a18ec2cb3fe2474941e2982e45b3ee2a7 /testing/getmail
parentf9a85640a0321cb63474ce6922325d0ca0847b72 (diff)
downloadaports-d2cb215b890e89603f9a58c3cab041466fd1b8f4.tar.bz2
aports-d2cb215b890e89603f9a58c3cab041466fd1b8f4.tar.xz
testing/getmail: upgrade to 5.6
Diffstat (limited to 'testing/getmail')
-rw-r--r--testing/getmail/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/getmail/APKBUILD b/testing/getmail/APKBUILD
index c8e95eaaa3..b643059c95 100644
--- a/testing/getmail/APKBUILD
+++ b/testing/getmail/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=getmail
-pkgver=4.50.0
+pkgver=5.6
pkgrel=0
pkgdesc="POP3, IMAP4, and SDPS mail retriever with Maildir delivery"
url="http://pyropus.ca/software/getmail/"
@@ -12,21 +12,20 @@ depends_dev=""
makedepends="python2-dev"
install=""
subpackages="$pkgname-doc"
+options="!check" # contains no tests
source="http://pyropus.ca/software/getmail/old-versions/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
# fix some broken shebang calls
sed -i -e "s|#![ ]*/usr/bin/env python2\.3|#!/usr/bin/env python2|" $(find $pkgdir -name '*.py')
}
-md5sums="4c31fdefbad549768227b35193ead908 getmail-4.50.0.tar.gz"
-sha256sums="fcbc77b9a14a2798a50725af9488d292bc97e983997947df1b9dcd9a0e288bc1 getmail-4.50.0.tar.gz"
-sha512sums="f8484fe907e82bd96abc6fea9e824a51608450921020d18522c6da00ddc5f0c1a2f9be0a534d1451830174d33e526e956a1bba9b7e9f2c987f765547848317c9 getmail-4.50.0.tar.gz"
+sha512sums="7ee34f214ab4d98d1b34e46abba61561133f27edf1f64bb9c5d5f671e6944724d1773234bd8ab626607b732cc54fd335cbfcb69fdff8f4d8fcdb33108b25bafd getmail-5.6.tar.gz"