aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gfbgraph
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-01 22:29:43 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 20:36:31 +0000
commit86455f1ed6db3f71930723b03391508c9e3efccf (patch)
treee755038486f2a3d1e53c829c657fb726b1d9b37a /testing/gfbgraph
parent491eaec7e8cb1a547aa58a318092efd3a80ef16b (diff)
downloadaports-86455f1ed6db3f71930723b03391508c9e3efccf.tar.bz2
aports-86455f1ed6db3f71930723b03391508c9e3efccf.tar.xz
testing/gfbgraph: new aport
Closes GH-8372
Diffstat (limited to 'testing/gfbgraph')
-rw-r--r--testing/gfbgraph/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/gfbgraph/APKBUILD b/testing/gfbgraph/APKBUILD
new file mode 100644
index 0000000000..2e53024c61
--- /dev/null
+++ b/testing/gfbgraph/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gfbgraph
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="GFBGraph is a GLib/GObject wrapper for the Facebook API"
+url="https://wiki.gnome.org/Projects/GFBGraph"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="gobject-introspection-dev gtk-doc glib-dev rest-dev json-glib-dev
+ libsoup-dev gnome-online-accounts-dev"
+options="!check" # Need valid FB credentials to work, so let's not
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/gfbgraph/${pkgver%.*}/gfbgraph-${pkgver}.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-gtk-doc
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4e03beb4172a591c7d1eb4cfac56009b0d25183168f73344d24ac47554334d1edf2c5087c523025cee5d565182a02dc7ef72adc66cff1e4ad53a1d0990d3afb8 gfbgraph-0.2.3.tar.xz"