aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gforth/APKBUILD
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-05-27 00:19:13 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-05-27 00:19:13 +0200
commit0f43c3750cd7ac98c6c69729b27d9081b2475abd (patch)
tree9ad8435f677f97af94ad583cc4cf6a8783d7b8fd /testing/gforth/APKBUILD
parent364639b0f8aa8058fe4d4becb8d6133fe9160042 (diff)
downloadaports-0f43c3750cd7ac98c6c69729b27d9081b2475abd.tar.bz2
aports-0f43c3750cd7ac98c6c69729b27d9081b2475abd.tar.xz
testing/gforth: new aport
Diffstat (limited to 'testing/gforth/APKBUILD')
-rw-r--r--testing/gforth/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/gforth/APKBUILD b/testing/gforth/APKBUILD
new file mode 100644
index 0000000000..e15ba24bfb
--- /dev/null
+++ b/testing/gforth/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=gforth
+pkgver=0.7.3
+pkgrel=0
+pkgdesc="Fast and portable implementation of the ANS Forth language"
+url="http://www.gnu.org/software/gforth/"
+arch="all"
+license="GPL-3"
+options="!check"
+makedepends="libffi-dev libtool m4"
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ CFLAGS='-std=gnu99' ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-check
+ make PREFIX=/usr -j1
+}
+
+check() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f034234acfb0fc727f28b564432219a100b916c6df4b847794a55b2fc3b8ed8714eca6de0df67c7c427b7c2bb4dd00f65cfd34e6eb60181e41ab84fea30304e4 gforth-0.7.3.tar.gz"