aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gforth
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 20:12:00 -0300
committerTBK <tbk@jjtc.eu>2019-05-27 02:20:31 +0200
commitd0c7fb8cf97250c1f5a29ea1b17ab66b4b06edea (patch)
treeba2fc2da6d831cf37a680dc336be6bd939edd3bb /testing/gforth
parent26162168d80ba2ab010348f00286736332515282 (diff)
downloadaports-d0c7fb8cf97250c1f5a29ea1b17ab66b4b06edea.tar.bz2
aports-d0c7fb8cf97250c1f5a29ea1b17ab66b4b06edea.tar.xz
testing/gforth: modernize, fix license.
Closes: GH-8169
Diffstat (limited to 'testing/gforth')
-rw-r--r--testing/gforth/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/gforth/APKBUILD b/testing/gforth/APKBUILD
index e7a3248351..4854545db7 100644
--- a/testing/gforth/APKBUILD
+++ b/testing/gforth/APKBUILD
@@ -2,23 +2,22 @@
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=gforth
pkgver=0.7.3
-pkgrel=0
+pkgrel=1
pkgdesc="Fast and portable implementation of the ANS Forth language"
url="http://www.gnu.org/software/gforth/"
arch="all !x86" # build fail on x86
-license="GPL-3"
-options="!check"
+license="GPL-3.0-or-later"
+options="!check" # Hangs
makedepends="libffi-dev libtool m4"
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz"
prepare() {
- default_prepare
- update_config_sub
+ default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
CFLAGS='-std=gnu99' ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,11 +30,10 @@ build() {
}
check() {
- cd "$builddir"
+ make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}