aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-crypt
diff options
context:
space:
mode:
authorLaurent Arnoud <laurent@spkdev.net>2019-04-13 12:35:23 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-14 18:52:26 +0000
commit8d20bb20347d49874a4da833db106e8f20284f77 (patch)
tree229b60d0d068f8163d3e291a230b5c8bc477ddee /testing/git-crypt
parentbed76860d2d5e156227300887d9c2d0b812dfce0 (diff)
downloadaports-8d20bb20347d49874a4da833db106e8f20284f77.tar.bz2
aports-8d20bb20347d49874a4da833db106e8f20284f77.tar.xz
testing/git-crypt: new aport
https://github.com/AGWA/git-crypt Transparent file encryption in git
Diffstat (limited to 'testing/git-crypt')
-rw-r--r--testing/git-crypt/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/git-crypt/APKBUILD b/testing/git-crypt/APKBUILD
new file mode 100644
index 0000000000..531cf86346
--- /dev/null
+++ b/testing/git-crypt/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Laurent Arnoud <laurent@spkdev.net>
+# Maintainer: Laurent Arnoud <laurent@spkdev.net>
+pkgname=git-crypt
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Transparent file encryption in git"
+url="https://www.agwa.name/projects/git-crypt"
+arch="all"
+license="GPL-3.0-or-later"
+depends="git"
+options="!check" # No test suite
+makedepends="docbook-xml docbook-xsl openssl-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/AGWA/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" ENABLE_MAN=yes install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="06fd9f6dbdc5c9fa9196f3e81a87cd3688089623b2658daf9c98809d5ca14df0b7ca69fdfe8279abf575957c366f2f93bd5a6885092eb533bd0d1ed9fe9dfac5 git-crypt-0.6.0.tar.gz"