aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-secret/makefile.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-06 01:28:48 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-06 01:29:54 +0200
commitf85d009eec06b341766ae98e05b284a7e0c00287 (patch)
treec0d4c9146776c7e900c7e0d978f18cee89403ebc /testing/git-secret/makefile.patch
parent57a51123a91675b55ce9fac8a1a9fe0822e244c8 (diff)
downloadaports-f85d009eec06b341766ae98e05b284a7e0c00287.tar.bz2
aports-f85d009eec06b341766ae98e05b284a7e0c00287.tar.xz
testing/git-secret: new aport
http://git-secret.io/ A bash-tool to store your private data inside a git repository
Diffstat (limited to 'testing/git-secret/makefile.patch')
-rw-r--r--testing/git-secret/makefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/git-secret/makefile.patch b/testing/git-secret/makefile.patch
new file mode 100644
index 0000000000..a864c95841
--- /dev/null
+++ b/testing/git-secret/makefile.patch
@@ -0,0 +1,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -39,10 +39,10 @@
+ git clone https://github.com/sstephenson/bats.git vendor/bats; fi
+
+ .PHONY: test
+-test: install-test clean build
++test: build
+ @chmod +x "./utils/tests.sh"; sync; \
+ export SECRET_PROJECT_ROOT="${PWD}"; \
+- export PATH="${PWD}/vendor/bats/bin:${PWD}:${PATH}"; \
++ export PATH="${PWD}:${PATH}"; \
+ "./utils/tests.sh"
+
+ #