aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gitstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/gitstats
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/gitstats')
-rw-r--r--testing/gitstats/APKBUILD46
-rw-r--r--testing/gitstats/gitstats-output.patch15
2 files changed, 0 insertions, 61 deletions
diff --git a/testing/gitstats/APKBUILD b/testing/gitstats/APKBUILD
deleted file mode 100644
index a85fb7fe56..0000000000
--- a/testing/gitstats/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=gitstats
-pkgver=2013.12.07
-pkgrel=0
-pkgdesc="Git history statistics generator"
-url="http://gitstats.sourceforge.net/"
-arch="noarch"
-license="GPL2+"
-depends="python gnuplot git"
-depends_dev=""
-makedepends=""
-install=""
-subpackages=""
-source="http://ftp.de.debian.org/debian/pool/main/g/$pkgname/"$pkgname"_$pkgver.orig.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
-}
-
-package() {
- cd "$_builddir"
- install -m755 -D "$_builddir"/$pkgname \
- "$pkgdir"/usr/sbin/$pkgname || return 1
-
- for _file in gitstats.css sortable.js *.gif; do
- install -Dm644 "$_builddir"/$_file \
- "$pkgdir"/usr/share/$pkgname/$_file || return 1
- done
-
-}
-
-md5sums="1a26e835b067d7eb45b73df49afe34ab gitstats_2013.12.07.orig.tar.gz"
-sha256sums="1250b78ac3a1f1946d4ee2ff98b7005c9dd8137647a95593e733d3de8d65f82f gitstats_2013.12.07.orig.tar.gz"
-sha512sums="3984b6236a1957fb457ea4b444b8b56f385451d50212af138412d5d040bc7d0ef67e5e2bb74b34b2193f7e25a8cd932a1477e5babd937578c4d83f50da0e25c0 gitstats_2013.12.07.orig.tar.gz"
diff --git a/testing/gitstats/gitstats-output.patch b/testing/gitstats/gitstats-output.patch
deleted file mode 100644
index 118a4cbb34..0000000000
--- a/testing/gitstats/gitstats-output.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- gitstats/gitstats.orig
-+++ gitstats/gitstats
-@@ -1376,10 +1376,8 @@
- exectime_internal = time_end - time_start
- print 'Execution time %.5f secs, %.5f secs (%.2f %%) in external commands)' % (exectime_internal, exectime_external, (100.0 * exectime_external) / exectime_internal)
- if sys.stdin.isatty():
-- print 'You may now run:'
-- print
-- print ' sensible-browser \'%s\'' % os.path.join(outputpath, 'index.html').replace("'", "'\\''")
-- print
-+ print 'The report is available at:'
-+ print '\'%s\'' % os.path.join(outputpath, 'index.html').replace("'", "'\\''")
-
- if __name__=='__main__':
- g = GitStats()