aboutsummaryrefslogtreecommitdiffstats
path: root/testing/global
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 15:58:00 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-28 13:26:24 +0000
commit986e263188318a40f33ac9c6a8c44b96bf3c606b (patch)
treeeb1eea11b16e8036b83acc45145d5614428b6c27 /testing/global
parentca307dba5de678e0a66d1d3ee1ec305728ae3672 (diff)
downloadaports-986e263188318a40f33ac9c6a8c44b96bf3c606b.tar.bz2
aports-986e263188318a40f33ac9c6a8c44b96bf3c606b.tar.xz
testing/global: upgrade to 6.6.3
Diffstat (limited to 'testing/global')
-rw-r--r--testing/global/APKBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/testing/global/APKBUILD b/testing/global/APKBUILD
index 5189a53c58..3a397cf6e7 100644
--- a/testing/global/APKBUILD
+++ b/testing/global/APKBUILD
@@ -1,35 +1,28 @@
# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
# Maintainer:
pkgname=global
-pkgver=6.6.2
-pkgrel=1
+pkgver=6.6.3
+pkgrel=0
pkgdesc="A source code tag system"
+options="!check" # No testsuite
url="https://www.gnu.org/software/global"
arch="all"
-license="GPL"
-depends=""
+license="GPL-3.0-or-later AND LGPL-3.0-or-later"
makedepends="libltdl perl"
subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/global/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--localstatedir=/var \
--with-exuberant-ctags=/usr/bin/ctags \
- --disable-gtagscscope
+ --disable-gtagscscope \
+ --disable-static
make
}
-check() {
- cd "$builddir"
- ./global/global --version
-}
-
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" install
install -d "$pkgdir"/usr/share/emacs/site-lisp
@@ -39,4 +32,4 @@ package() {
mv "$pkgdir"/usr/share/gtags/gtags-cscope.vim "$pkgdir"/usr/share/vim/vimfiles/plugin/gtags-cscope.vim
}
-sha512sums="9a58e4c2128bd420068754a5f93a472efa7ce12589dc291ebc0b6f4af8e2a5113d47ffa6887fc61ed1d6370529ced55826f25b484ac16416bced99235c01d744 global-6.6.2.tar.gz"
+sha512sums="1edeb571e9105fb9c2a217bbfbcc3f273be1d7f078921c2ce1a9acb60ed1330268df6a68248a9676476338e74c4a77fb37bff68a6bf37f958ba99502b5c5755d global-6.6.3.tar.gz"