aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gn
diff options
context:
space:
mode:
authorSven Assmann <sven@d34dl0ck.me>2019-02-19 01:05:22 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-22 18:53:33 +0000
commit7fe22bb830219e7e8c97ec257eca6044a9137a85 (patch)
tree1f5a3b000c56f3a443e6d712d40983ef85654ee9 /testing/gn
parent1bbe87ce5cd4866ea62dc8c8212affdf04f04aa8 (diff)
downloadaports-7fe22bb830219e7e8c97ec257eca6044a9137a85.tar.bz2
aports-7fe22bb830219e7e8c97ec257eca6044a9137a85.tar.xz
testing/gn: new aport
https://gn.googlesource.com/gn/+/refs/heads/master/README.md GN is a meta-build system that generates build files for Ninja.
Diffstat (limited to 'testing/gn')
-rw-r--r--testing/gn/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/gn/APKBUILD b/testing/gn/APKBUILD
new file mode 100644
index 0000000000..a289cc10f1
--- /dev/null
+++ b/testing/gn/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sven Assmann <sven@d34dl0ck.me>
+pkgname=gn
+pkgver=1530
+pkgrel=0
+pkgdesc="GN is a meta-build system that generates build files for Ninja."
+url="https://gn.googlesource.com/gn/+/1ab6fa2c/README.md"
+arch="all"
+license="BSD-3-Clause"
+depends="libgcc musl"
+makedepends="python2 ninja git clang"
+giturl="https://gn.googlesource.com/gn"
+builddir="$srcdir"
+
+fetch() {
+ git clone https://gn.googlesource.com/gn "$builddir/git"
+ cd "$builddir/git"
+ git reset --hard 1ab6fa2c
+}
+
+prepare() {
+ "$builddir/git/build/gen.py"
+}
+
+build() {
+ cd "$builddir/git"
+ ninja -C out -j 8
+}
+
+package() {
+ install -m755 -D "$builddir/git/out/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}