aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-settings-daemon/no-wayland-support.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 10:23:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:28:44 +0000
commitd28004e95fa67eb4e2662feed5523bdcc767e846 (patch)
tree516f11f69230c0924937386d7924a10f11d5e08c /testing/gnome-settings-daemon/no-wayland-support.patch
parent21e70eae871680d51654c71bdd8ed3b841b78acc (diff)
downloadaports-d28004e95fa67eb4e2662feed5523bdcc767e846.tar.bz2
aports-d28004e95fa67eb4e2662feed5523bdcc767e846.tar.xz
testing/gnome-settings-daemon: upgrade to 3.26.0, modernize APKBUILD
Diffstat (limited to 'testing/gnome-settings-daemon/no-wayland-support.patch')
-rw-r--r--testing/gnome-settings-daemon/no-wayland-support.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/gnome-settings-daemon/no-wayland-support.patch b/testing/gnome-settings-daemon/no-wayland-support.patch
new file mode 100644
index 0000000000..3a55ef2afd
--- /dev/null
+++ b/testing/gnome-settings-daemon/no-wayland-support.patch
@@ -0,0 +1,34 @@
+
+Note: This is needed since gtk+3.0 is not compiled with the option : --enable-wayland-backend
+therefore, the gdk/gdkwayland.h is not included in gtk+3.0-dev package.
+fcolista@alpinelinux.org
+
+diff '--exclude=.git' -urN a/plugins/common/gsd-device-manager-udev.c b/plugins/common/gsd-device-manager-udev.c
+--- a/plugins/common/gsd-device-manager-udev.c 2017-07-22 12:29:49.000000000 -0400
++++ b/plugins/common/gsd-device-manager-udev.c 2017-07-27 05:25:11.728250282 -0400
+@@ -24,7 +24,9 @@
+ #include <string.h>
+ #include <gudev/gudev.h>
+
++#ifdef GDK_WINDOWING_WAYLAND
+ #include <gdk/gdkwayland.h>
++#endif
+ #include "gsd-device-manager-udev.h"
+
+ struct _GsdUdevDeviceManager
+@@ -233,6 +235,7 @@
+ gsd_udev_device_manager_lookup_device (GsdDeviceManager *manager,
+ GdkDevice *gdk_device)
+ {
++#ifdef GDK_WINDOWING_WAYLAND
+ const gchar *node_path;
+ GHashTableIter iter;
+ GsdDevice *device;
+@@ -249,6 +252,7 @@
+ return device;
+ }
+ }
++#endif
+
+ return NULL;
+ }