aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-settings-daemon
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-01 13:08:50 +0200
committerTBK <tbk@jjtc.eu>2019-05-25 18:06:06 +0200
commit2600dd8766a0f46fd2a86f219caf9a9a08777803 (patch)
tree6293ca8729366b4b4f951d3e31ff846a57d2ea7f /testing/gnome-settings-daemon
parent98aef0ad310ddb55491ec607b5e5510fedafafe1 (diff)
downloadaports-2600dd8766a0f46fd2a86f219caf9a9a08777803.tar.bz2
aports-2600dd8766a0f46fd2a86f219caf9a9a08777803.tar.xz
testing/gnome-settings-daemon: update to 3.32.0
Closes: GH-7379
Diffstat (limited to 'testing/gnome-settings-daemon')
-rw-r--r--testing/gnome-settings-daemon/APKBUILD36
-rw-r--r--testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch30
-rw-r--r--testing/gnome-settings-daemon/initial-keyboard.patch67
-rw-r--r--testing/gnome-settings-daemon/no-wayland-support.patch34
4 files changed, 14 insertions, 153 deletions
diff --git a/testing/gnome-settings-daemon/APKBUILD b/testing/gnome-settings-daemon/APKBUILD
index 2465dfb357..af25187051 100644
--- a/testing/gnome-settings-daemon/APKBUILD
+++ b/testing/gnome-settings-daemon/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-settings-daemon
-pkgver=3.26.0
-pkgrel=2
+pkgver=3.32.0
+pkgrel=0
pkgdesc="GNOME settings daemon"
url="https://www.gnome.org/"
arch="all !s390x"
@@ -11,36 +11,28 @@ depends_dev="gnome-desktop-dev libnotify-dev
libcanberra-dev colord-dev geoclue-dev
libgweather-dev geocode-glib-dev
pulseaudio-dev upower-dev libwacom-dev
- cups-dev networkmanager-dev"
-makedepends="$depends_dev libxml2-utils"
+ cups-dev networkmanager-dev polkit-dev
+ lcms2-dev nss-dev"
+makedepends="$depends_dev libxml2-utils meson py3-setuptools"
+depends="pulseaudio"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/gnome-settings-daemon/${pkgver%.*}/gnome-settings-daemon-$pkgver.tar.xz
- initial-keyboard.patch
- no-wayland-support.patch
- housekeeping-fix-improper-notify_notification_close_usage.patch
- "
+source="https://download.gnome.org/sources/gnome-settings-daemon/${pkgver%.*}/gnome-settings-daemon-$pkgver.tar.xz"
builddir="$srcdir/gnome-settings-daemon-$pkgver"
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
- --enable-static=no \
--sysconfdir=/etc \
- --mandir=/usr/share/man \
--localstatedir=/var \
- --disable-wayland
- make
+ --buildtype=release \
+ . output
+ ninja -C output
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="4338c097fa6bd148ae6ce4b6b04609ccaa6b896dd65cbecbc3a16fdae186e926860cbebddc1aab21c3c9c7af1b68000f0a69cbc7887c4533aade2a0cfd9780bb gnome-settings-daemon-3.26.0.tar.xz
-235986a8fdbaaebfb5a8d351532ea6621c4359bccd34f45f3addbe1b8ec051f6c52487b947a4db881441f8f8f484e5ddb26b4501ae34ee7444c73004526ab0b7 initial-keyboard.patch
-3c4403afdc40ff565d0c53af24aad17038dde93d97b3996c318094bc21dc7576a4f603b4744a42325b154e3e123ff6f04a9f3c2523879f07a64dc8efbd6e912d no-wayland-support.patch
-d406ef54e15c919c8cbe18ec8f69716f72d2fd7a7c270ae15c169e6e1392d07650bea9e85a0f919b5e78417a19122ff4329d5f243a245042f10531147ab91367 housekeeping-fix-improper-notify_notification_close_usage.patch"
+sha512sums="9b4c322ae063f62a934c730a4aed0de1486de60007dd84c31829f607e656cd90d03c0ddae0d0bb477dbc68f0313be06a6c566d54d111817177afb64b1784542a gnome-settings-daemon-3.32.0.tar.xz"
diff --git a/testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch b/testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch
deleted file mode 100644
index 0bd07fdf8b..0000000000
--- a/testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3110457f72f70b2d283c1ad2f27b91b95d75d92f Mon Sep 17 00:00:00 2001
-From: Christian Hergert <chergert@redhat.com>
-Date: Wed, 18 Jul 2018 19:31:17 -0700
-Subject: [PATCH] housekeeping: fix improper notify_notification_close() usage
-
-notify_notification_close() expects that a parameter will be available for
-the error location, which could be a dangling pointer in a register or
-on the stack in the case of some architectures.
-
-This was caught by GNOME/glib#1425 which allows us to check proper type
-parameters.
----
- plugins/housekeeping/gsd-disk-space.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/plugins/housekeeping/gsd-disk-space.c b/plugins/housekeeping/gsd-disk-space.c
-index 0ae40193aa..0eee94ea9b 100644
---- a/plugins/housekeeping/gsd-disk-space.c
-+++ b/plugins/housekeeping/gsd-disk-space.c
-@@ -1017,7 +1017,9 @@ gsd_ldsm_clean (void)
- g_clear_object (&ldsm_monitor);
- g_clear_object (&settings);
- g_clear_object (&privacy_settings);
-- g_clear_pointer (&notification, notify_notification_close);
-+ /* NotifyNotification::closed callback will drop reference */
-+ if (notification != NULL)
-+ notify_notification_close (notification, NULL);
- g_slist_free_full (ignore_paths, g_free);
- ignore_paths = NULL;
- }
diff --git a/testing/gnome-settings-daemon/initial-keyboard.patch b/testing/gnome-settings-daemon/initial-keyboard.patch
deleted file mode 100644
index 7a08b7fbd8..0000000000
--- a/testing/gnome-settings-daemon/initial-keyboard.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From c2e0c03c03f47da9b117db0ba876732e84dcf0c4 Mon Sep 17 00:00:00 2001
-From: Federico Mena Quintero <federico@gnome.org>
-Date: Mon, 16 May 2016 19:18:43 -0500
-Subject: [PATCH] Resurrect the code from upstream to set the default keyboard
- from XKB if there is one.
-
-Suse works differently than GNOME here; we set a default keyboard from
-the system's configuration instead of letting GNOME take care of
-everything itself.
-
-https://bugzilla.suse.com/show_bug.cgi?id=979051
----
- plugins/keyboard/gsd-keyboard-manager.c | 18 +++++++++++++-----
- 1 file changed, 13 insertions(+), 5 deletions(-)
-
-diff --git a/plugins/keyboard/gsd-keyboard-manager.c b/plugins/keyboard/gsd-keyboard-manager.c
-index eb75c92..06be608 100644
---- a/plugins/keyboard/gsd-keyboard-manager.c
-+++ b/plugins/keyboard/gsd-keyboard-manager.c
-@@ -450,7 +450,7 @@ input_sources_changed (GSettings *settings,
- }
-
- static void
--get_sources_from_xkb_config (GsdKeyboardManager *manager)
-+get_sources_from_xkb_config (GsdKeyboardManager *manager, gboolean running_under_gdm)
- {
- GsdKeyboardManagerPrivate *priv = manager->priv;
- GVariantBuilder builder;
-@@ -501,7 +501,7 @@ get_sources_from_xkb_config (GsdKeyboardManager *manager)
-
- init_builder_with_sources (&builder, priv->input_sources_settings);
-
-- if (!layouts) {
-+ if (!layouts && running_under_gdm) {
- g_variant_builder_add (&builder, "(ss)", INPUT_SOURCE_TYPE_XKB, DEFAULT_LAYOUT);
- goto out;
- }
-@@ -653,15 +653,23 @@ maybe_create_initial_settings (GsdKeyboardManager *manager)
-
- settings = manager->priv->input_sources_settings;
-
-- if (g_getenv ("RUNNING_UNDER_GDM"))
-- return;
-+ if (g_getenv ("RUNNING_UNDER_GDM")) {
-+ GVariantBuilder builder;
-+ /* clean the settings and get them from the "system" */
-+ g_variant_builder_init (&builder, G_VARIANT_TYPE ("a(ss)"));
-+ g_settings_set_value (settings, KEY_INPUT_SOURCES, g_variant_builder_end (&builder));
-+ get_sources_from_xkb_config (manager, TRUE);
-+
-+ g_settings_set_strv (settings, KEY_KEYBOARD_OPTIONS, NULL);
-+ get_options_from_xkb_config (manager);
-+ }
-
- maybe_convert_old_settings (settings);
-
- /* if we still don't have anything do some educated guesses */
- sources = g_settings_get_value (settings, KEY_INPUT_SOURCES);
- if (g_variant_n_children (sources) < 1)
-- get_sources_from_xkb_config (manager);
-+ get_sources_from_xkb_config (manager, FALSE);
- g_variant_unref (sources);
-
- options = g_settings_get_strv (settings, KEY_KEYBOARD_OPTIONS);
---
-2.1.4
-
diff --git a/testing/gnome-settings-daemon/no-wayland-support.patch b/testing/gnome-settings-daemon/no-wayland-support.patch
deleted file mode 100644
index 3a55ef2afd..0000000000
--- a/testing/gnome-settings-daemon/no-wayland-support.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-
-Note: This is needed since gtk+3.0 is not compiled with the option : --enable-wayland-backend
-therefore, the gdk/gdkwayland.h is not included in gtk+3.0-dev package.
-fcolista@alpinelinux.org
-
-diff '--exclude=.git' -urN a/plugins/common/gsd-device-manager-udev.c b/plugins/common/gsd-device-manager-udev.c
---- a/plugins/common/gsd-device-manager-udev.c 2017-07-22 12:29:49.000000000 -0400
-+++ b/plugins/common/gsd-device-manager-udev.c 2017-07-27 05:25:11.728250282 -0400
-@@ -24,7 +24,9 @@
- #include <string.h>
- #include <gudev/gudev.h>
-
-+#ifdef GDK_WINDOWING_WAYLAND
- #include <gdk/gdkwayland.h>
-+#endif
- #include "gsd-device-manager-udev.h"
-
- struct _GsdUdevDeviceManager
-@@ -233,6 +235,7 @@
- gsd_udev_device_manager_lookup_device (GsdDeviceManager *manager,
- GdkDevice *gdk_device)
- {
-+#ifdef GDK_WINDOWING_WAYLAND
- const gchar *node_path;
- GHashTableIter iter;
- GsdDevice *device;
-@@ -249,6 +252,7 @@
- return device;
- }
- }
-+#endif
-
- return NULL;
- }