aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-shell
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 20:17:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-06 00:20:31 -0300
commit20eddcb494f5f3f5597cab12227a6aa7b90b61c2 (patch)
tree0de6e3dfa1325e8a7bb9b797d11910311ce133d0 /testing/gnome-shell
parent5a9029d909f3afa2be5f2826e2bf5ecb3726e64b (diff)
downloadaports-20eddcb494f5f3f5597cab12227a6aa7b90b61c2.tar.bz2
aports-20eddcb494f5f3f5597cab12227a6aa7b90b61c2.tar.xz
testing/gnome-shell: use xvfb-run to run testsuite
Sadly the tests require on gdm which depends on gnome-shell so we can't enable them, but still, individual maintainers when updating gnome-shell can make use of an already compiled gdm to run the testsuite.
Diffstat (limited to 'testing/gnome-shell')
-rw-r--r--testing/gnome-shell/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/gnome-shell/APKBUILD b/testing/gnome-shell/APKBUILD
index 2c15ea3e69..c58ae1ce6c 100644
--- a/testing/gnome-shell/APKBUILD
+++ b/testing/gnome-shell/APKBUILD
@@ -45,9 +45,14 @@ makedepends="gnome-desktop-dev
py3-setuptools
gnome-bluetooth-dev
gstreamer-dev"
+checkdepends="
+ xvfb-run
+ mesa-dri-swrast
+ gdm
+ "
subpackages="$pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/gnome-shell/${pkgver%.*}/gnome-shell-$pkgver.tar.xz"
-options="!check" # Requires running X11 server
+options="!check" # Tests have circular dependency 'gnome-shell <-> gdm'
build() {
meson \
@@ -62,7 +67,7 @@ build() {
}
check() {
- ninja -C output test
+ xvfb-run ninja -C output test
}
package() {