aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-httputils
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 08:56:23 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 08:56:23 +0000
commitafeceac8bea618a79480841a484aae91a98284e1 (patch)
tree355a463b014f62aabccffd6934cd567e7fd8d66b /testing/go-httputils
parent1d5e71d35028b9d3af112ad941347bc6c1b510be (diff)
downloadaports-afeceac8bea618a79480841a484aae91a98284e1.tar.bz2
aports-afeceac8bea618a79480841a484aae91a98284e1.tar.xz
testing/go-httputils: modernize APKBUILD, update license, disable check()
Take maintainership
Diffstat (limited to 'testing/go-httputils')
-rw-r--r--testing/go-httputils/APKBUILD33
1 files changed, 12 insertions, 21 deletions
diff --git a/testing/go-httputils/APKBUILD b/testing/go-httputils/APKBUILD
index 0e5ae8ad37..09ea75502d 100644
--- a/testing/go-httputils/APKBUILD
+++ b/testing/go-httputils/APKBUILD
@@ -1,44 +1,35 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-httputils
-_realname=httputils
+_pkgname=httputils
_vendor="strukturag"
pkgver=012
pkgrel=0
pkgdesc="Go support library for HTTP servers"
-url="https://github.com/$_vendor/$_realname"
+url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="BSD-3-Clause"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_realname/archive/${_realname}_v$pkgver.tar.gz"
-builddir="$srcdir"/${_realname}-${_realname}_v$pkgver
-
-
-prepare() {
- cd "$builddir"
-}
+options="!check" # no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_pkgname/archive/${_pkgname}_v$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname}-${_pkgname}_v$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
AUTHORS \
; do \
- test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$_realname
+ test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$_pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
md5sums="7c1a1b13471098238e8714dc87a144fd go-httputils-012.tar.gz"