aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-phoenix
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 15:12:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 15:13:53 +0000
commit225d7115b182c476bd3beb0fadf66b79c2fb79b7 (patch)
tree90a5bb219c8ad00c66e162c7284ca23fc8af1eb1 /testing/go-phoenix
parent493512b29e9ab872d585b82fcbd5bb0e82d10a64 (diff)
downloadaports-225d7115b182c476bd3beb0fadf66b79c2fb79b7.tar.bz2
aports-225d7115b182c476bd3beb0fadf66b79c2fb79b7.tar.xz
testing/go-phoenix: depends on go, APKBUILD var name update
Really take maintainership
Diffstat (limited to 'testing/go-phoenix')
-rw-r--r--testing/go-phoenix/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/testing/go-phoenix/APKBUILD b/testing/go-phoenix/APKBUILD
index 9d53f9b6ad..bd19e3be1a 100644
--- a/testing/go-phoenix/APKBUILD
+++ b/testing/go-phoenix/APKBUILD
@@ -1,19 +1,19 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-phoenix
-_realname=phoenix
+_pkgname=phoenix
_vendor="strukturag"
pkgver=1.0.2
_ver=${pkgver//./}
-pkgrel=1
+pkgrel=2
pkgdesc="Go library providing support functionality for application startup, configuration, logging, and profiling."
-url="https://github.com/$_vendor/$_realname"
+url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
license="BSD-3-Clause"
+depends="go"
subpackages="$pkgname-doc"
options="!check" # no testsuite
-source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_realname/archive/${_realname}_v$_ver.tar.gz"
-builddir="$srcdir"/$_realname-${_realname}_v$_ver
+source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_pkgname/archive/${_pkgname}_v$_ver.tar.gz"
+builddir="$srcdir"/$_pkgname-${_pkgname}_v$_ver
build() {
return 0
@@ -22,7 +22,7 @@ build() {
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
README.* \
@@ -31,7 +31,7 @@ package() {
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
sha512sums="7b673e57135098b99fcc54cbe6b72dbd84a0342e2f8371e3b815e0a7598c2e4d4dccbbe6a71d250b88f9ad9ce285a4e108886ff3d2a77acc7eba1cf19bd4f7a2 go-phoenix-1.0.2.tar.gz"