aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-sloth/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:41:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:41:43 +0000
commitf7d7400a073f9a3a8fec43d15a7d750ba91c7197 (patch)
tree255ee2e5bda2c2688d7d150c28d66f324fa5802e /testing/go-sloth/APKBUILD
parent801786f5595783eec2db063c739bfd879728af3d (diff)
downloadaports-f7d7400a073f9a3a8fec43d15a7d750ba91c7197.tar.bz2
aports-f7d7400a073f9a3a8fec43d15a7d750ba91c7197.tar.xz
testing/go-sloth: modernize APKBULD, update license, disable check()
Take maintainership
Diffstat (limited to 'testing/go-sloth/APKBUILD')
-rw-r--r--testing/go-sloth/APKBUILD35
1 files changed, 12 insertions, 23 deletions
diff --git a/testing/go-sloth/APKBUILD b/testing/go-sloth/APKBUILD
index c589438578..0c20831786 100644
--- a/testing/go-sloth/APKBUILD
+++ b/testing/go-sloth/APKBUILD
@@ -1,46 +1,35 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-sloth
-_realname=sloth
+_pkgname=sloth
_vendor="strukturag"
pkgver=0.9.2
pkgrel=0
pkgdesc="A tiny REST framework for Go"
-url="https://github.com/$_vendor/$_realname"
+url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="MIT"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/${_realname}-$pkgver
-
-
-prepare() {
- cd "$builddir"
-}
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname}-$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
- AUTHORS \
+ AUTHORS.* \
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv *.go "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
-md5sums="4a40690a4ca65f65f452007a57c26a64 go-sloth-0.9.2.tar.gz"
-sha256sums="4a4757d85eae8d84b5da1579267b2f80ffd38044db665718b5b6522c9748de5c go-sloth-0.9.2.tar.gz"
sha512sums="2d7550e2cd0f7ae259567a5611886bb70132ca0bf5fc7e85f80f6cb31233cc45120cd8feb862666f31b43fd95de83713e7cfc38687074ea6659b9dd6dbd08332 go-sloth-0.9.2.tar.gz"