aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gocryptfs
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2020-02-24 21:53:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 18:23:45 -0300
commit9c1a0be37ed1ae644b6998bee21451cae40c5437 (patch)
tree9e2c1fc8ecf99ea342441615288ac6e0086a5a4b /testing/gocryptfs
parentff0ba778a6651a6d66c94171e62dd4644c239039 (diff)
downloadaports-9c1a0be37ed1ae644b6998bee21451cae40c5437.tar.bz2
aports-9c1a0be37ed1ae644b6998bee21451cae40c5437.tar.xz
testing/gocryptfs: new aport
Diffstat (limited to 'testing/gocryptfs')
-rw-r--r--testing/gocryptfs/APKBUILD38
-rw-r--r--testing/gocryptfs/remove_pandoc.patch18
2 files changed, 56 insertions, 0 deletions
diff --git a/testing/gocryptfs/APKBUILD b/testing/gocryptfs/APKBUILD
new file mode 100644
index 0000000000..5e93fc487f
--- /dev/null
+++ b/testing/gocryptfs/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=gocryptfs
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="Encrypted overlay filesystem written in Go."
+url="https://github.com/rfjakob/gocryptfs"
+arch="all"
+license="MIT"
+makedepends="go coreutils bash openssl-dev"
+depends="fuse"
+options="!check" # test requires fuse kernel module
+source="https://github.com/rfjakob/gocryptfs/releases/download/v$pkgver/gocryptfs_v${pkgver}_src-deps.tar.gz
+ remove_pandoc.patch"
+builddir="$srcdir/gopath/src/github.com/rfjakob/$pkgname"
+
+prepare() {
+ mkdir -p "$srcdir/gopath/src/github.com/rfjakob"
+ ln -rTsf "$srcdir/${pkgname}_v${pkgver}_src-deps" "$srcdir/gopath/src/github.com/rfjakob/$pkgname"
+ default_prepare
+}
+
+build() {
+ export GOPATH="$srcdir/gopath"
+ make build
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/share/licenses
+}
+
+sha512sums="7ab22100adee2bc880ffb09f5adafe269dee481d50497ee7a3c8c24405d229f26a22f6cec635230d6bd1753d702f9de08c537f313d02ba46fd5c754be59e2146 gocryptfs_v1.7.1_src-deps.tar.gz
+602468bf28273a99361d6610bec75c81deb5e7d42026f82d6fcab06dabd3312dcf2b1ba2411e02e86bc4842af9d53e6ef023013b93afd39bd1823ad76ff8a157 remove_pandoc.patch"
diff --git a/testing/gocryptfs/remove_pandoc.patch b/testing/gocryptfs/remove_pandoc.patch
new file mode 100644
index 0000000000..5f88f117e2
--- /dev/null
+++ b/testing/gocryptfs/remove_pandoc.patch
@@ -0,0 +1,18 @@
+diff -ruN gocryptfs_v1.7.1_src-deps/Makefile gocryptfs_v1.7.1_src-deps/Makefile
+--- gocryptfs_v1.7.1_src-deps/Makefile
++++ gocryptfs_v1.7.1_src-deps/Makefile
+@@ -1,7 +1,6 @@
+ .phony: build
+ build:
+ ./build.bash
+- ./Documentation/MANPAGE-render.bash
+
+ .phony: test
+ test:
+@@ -20,6 +19,4 @@
+ install:
+ install -Dm755 -t "$(DESTDIR)/usr/bin/" gocryptfs
+ install -Dm755 -t "$(DESTDIR)/usr/bin/" gocryptfs-xray/gocryptfs-xray
+- install -Dm644 -t "$(DESTDIR)/usr/share/man/man1/" Documentation/gocryptfs.1
+- install -Dm644 -t "$(DESTDIR)/usr/share/man/man1/" Documentation/gocryptfs-xray.1
+ install -Dm644 -t "$(DESTDIR)/usr/share/licenses/gocryptfs" LICENSE