aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gogs
diff options
context:
space:
mode:
author7heo <7heo@mail.com>2016-07-29 12:27:13 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-29 14:04:39 +0200
commit239c51d48e818ed52f018092918a1e042bba922b (patch)
tree0959693feacd0f7e0e073901cc3c220dbe747fc3 /testing/gogs
parent29342e7fec72ee44bc0f12c0fad15f2daf3e91fb (diff)
downloadaports-239c51d48e818ed52f018092918a1e042bba922b.tar.bz2
aports-239c51d48e818ed52f018092918a1e042bba922b.tar.xz
testing/gogs: fix the glide files path
As clandmeter noticed, the glide files should be copied from $srcdir and not from $startdir. Also reformatted the APKBUILD to fit in 80 cols when possible, and removed the extra (buggy) indentation that was there to align the next lines with the previous (but only when ts=8).
Diffstat (limited to 'testing/gogs')
-rw-r--r--testing/gogs/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/testing/gogs/APKBUILD b/testing/gogs/APKBUILD
index 3ba51bf9e4..7655400e69 100644
--- a/testing/gogs/APKBUILD
+++ b/testing/gogs/APKBUILD
@@ -24,21 +24,22 @@ builddir="$srcdir/${pkgname}-${pkgver}"
build() {
export GOPATH="$startdir"
cd "$builddir" || return 1
- cp "$startdir/glide.yaml" "$startdir/glide.lock" .
+ cp "$srcdir/glide.yaml" "$srcdir/glide.lock" .
glide install || return 1
go fix || return 1
- go build -buildmode=pie -v -tags "sqlite redis memcache cert" || return 1 # sqlite causes problems without the pie buildmode
+ # Note: sqlite causes problems without the pie buildmode
+ go build -buildmode=pie -v -tags "sqlite redis memcache cert" ||return 1
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/webapps/$pkgname \
- "$pkgdir"/var/lib/$pkgname/git \
- "$pkgdir"/var/lib/$pkgname/db \
- "$pkgdir"/var/lib/$pkgname/avatars \
- "$pkgdir"/var/lib/$pkgname/attachements \
- "$pkgdir"/var/cache/$pkgname/sessions \
- "$pkgdir"/var/log/$pkgname || return 1
+ "$pkgdir"/var/lib/$pkgname/git \
+ "$pkgdir"/var/lib/$pkgname/db \
+ "$pkgdir"/var/lib/$pkgname/avatars \
+ "$pkgdir"/var/lib/$pkgname/attachements \
+ "$pkgdir"/var/cache/$pkgname/sessions \
+ "$pkgdir"/var/log/$pkgname || return 1
chown -R gogs:www-data "$pkgdir"/var/lib/$pkgname \
"$pkgdir"/var/cache/gogs/sessions \
"$pkgdir"/var/log/$pkgname || return 1
@@ -48,7 +49,7 @@ package() {
setcap cap_net_bind_service=+ep \
"$pkgdir"/usr/bin/$pkgname || return 1
install -d -o gogs -g www-data \
- "$pkgdir"/etc/$pkgname/conf || return 1
+ "$pkgdir"/etc/$pkgname/conf || return 1
install -D -m 0664 -o gogs -g www-data "$srcdir"/${pkgname}.ini \
"$pkgdir"/etc/$pkgname/conf/app.ini || return 1
mv public "$pkgdir"/usr/share/webapps/$pkgname/ || return 1