aboutsummaryrefslogtreecommitdiffstats
path: root/testing/goomwwm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-19 08:01:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-19 08:03:20 +0000
commite43456478be2c6ec5a36bc9e920a3b91fd332163 (patch)
tree1cdf8123197a055bdf45691961655fe8e62245fe /testing/goomwwm
parentd22faae9b5681b7f18cb44650a920aac69a2d40e (diff)
downloadaports-e43456478be2c6ec5a36bc9e920a3b91fd332163.tar.bz2
aports-e43456478be2c6ec5a36bc9e920a3b91fd332163.tar.xz
testing/goomwwm: misc cleanups
- change ${variable} to $variable - proper use of $builddir - let abuild handle runtime dependencies
Diffstat (limited to 'testing/goomwwm')
-rw-r--r--testing/goomwwm/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/testing/goomwwm/APKBUILD b/testing/goomwwm/APKBUILD
index b0551a1eb4..4054f2834e 100644
--- a/testing/goomwwm/APKBUILD
+++ b/testing/goomwwm/APKBUILD
@@ -7,26 +7,24 @@ pkgdesc="Get out of my way, Window Manager!"
url="https://github.com/seanpringle/goomwwm"
arch="all"
license="MIT"
-depends="libxft libx11 libxinerama freetype"
-makedepends="libx11-dev libxft-dev freetype-dev libxinerama-dev libx11 libxft
- pkgconfig xorgproto"
-source="${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
-builddir="$srcdir/"
-_builddir="${builddir}/${pkgname}-${pkgver}"
+depends=""
+makedepends="libx11-dev libxft-dev freetype-dev libxinerama-dev xorgproto"
+source="$pkgname-$pkgver.tar.gz::https://github.com/seanpringle/goomwwm/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "${_builddir}"
+ cd "$builddir"
make proto normal
}
check() {
- cd "${_builddir}"
- ./${pkgname} --version
+ cd "$builddir"
+ ./goomwwm --version
}
package() {
- mkdir -p "${pkgdir}"
- install -m755 -D "${_builddir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ mkdir -p "$pkgdir"
+ install -m755 -D "$builddir"/goomwwm "$pkgdir"/usr/bin/$pkgname
}
sha512sums="e37d80c8ea47fe136172c392521ec8d4dab361c3469d3d1626ed7c30385513301983c0ffde39f4c2e6f2dee8709da6a34f14f7bb89776f1ccde5103ab1a26764 goomwwm-1.0.0.tar.gz"