aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gource/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-14 12:42:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-14 12:42:37 +0000
commit973f3e84fdc596347cf68d6daafbe283761e9888 (patch)
treeef7e9545161a6742c11c2400a970a3aa256167c1 /testing/gource/APKBUILD
parent7e666583459c8a2a683562359a6e8ab2f545573e (diff)
parente0fdaf5420129da4762f1b93150ead3f481d72e4 (diff)
downloadaports-973f3e84fdc596347cf68d6daafbe283761e9888.tar.bz2
aports-973f3e84fdc596347cf68d6daafbe283761e9888.tar.xz
Merge git://git.alpinelinux.org/fcolista/aports-fcolista
Diffstat (limited to 'testing/gource/APKBUILD')
-rw-r--r--testing/gource/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/gource/APKBUILD b/testing/gource/APKBUILD
new file mode 100644
index 0000000000..d4414e2912
--- /dev/null
+++ b/testing/gource/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=gource
+pkgver=0.32
+pkgrel=0
+pkgdesc="Software version control visualization"
+url="http://code.google.com&p/gource"
+arch="all"
+license="GPL3"
+depends=
+depends_dev="ftgl-dev sdl-dev sdl_image-dev pcre-dev glew-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://gource.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7aed2fcf8f0c09b8cea5b19a418b0724 gource-0.32.tar.gz"