aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gpm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 15:35:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-08 04:07:32 -0300
commitc5a8dac6ab18d7fe88ab46d574e97e10010f3709 (patch)
tree1065cba1a16f2546bd726e2b5488011183bdc1f7 /testing/gpm
parentf08cb707e1a1ba3a15ef4a0fd14c479587a26b6b (diff)
downloadaports-c5a8dac6ab18d7fe88ab46d574e97e10010f3709.tar.bz2
aports-c5a8dac6ab18d7fe88ab46d574e97e10010f3709.tar.xz
testing/gpm: fix url fix license
Diffstat (limited to 'testing/gpm')
-rw-r--r--testing/gpm/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/testing/gpm/APKBUILD b/testing/gpm/APKBUILD
index cee2ef3df3..ab8faf268b 100644
--- a/testing/gpm/APKBUILD
+++ b/testing/gpm/APKBUILD
@@ -2,16 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gpm
pkgver=1.20.7
-pkgrel=0
+pkgrel=1
pkgdesc="A mouse server for the console"
-url="http://www.nico.schottelius.org/software/gpm/"
+options="!check" # No testsuite
+url="https://www.nico.schottelius.org/software/gpm/"
arch="all"
-license="GPL-2.0"
-depends=""
+license="GPL-2.0-or-later"
depends_dev="$pkgname-libs"
makedepends="$depends_dev texinfo autoconf automake libtool bison linux-headers
ncurses-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-utils
$pkgname-openrc"
source="http://www.nico.schottelius.org/software/gpm/archives/$pkgname-$pkgver.tar.bz2
@@ -27,11 +26,12 @@ source="http://www.nico.schottelius.org/software/gpm/archives/$pkgname-$pkgver.t
$pkgname.confd
"
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
build() {
- cd "$builddir"
- ./autogen.sh
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,12 +39,12 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd \