aboutsummaryrefslogtreecommitdiffstats
path: root/testing/grub/fix-gcc-no-pie-specs.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-09-13 10:49:11 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-09-13 10:52:18 +0200
commit18933df139abc4bc2aed9363e7524846bec79dfa (patch)
treec4c7a66ca8f3df221500cd244ede11af34b73262 /testing/grub/fix-gcc-no-pie-specs.patch
parent315bf29a27f672f9a6c8fb4658969856c6910d30 (diff)
downloadaports-18933df139abc4bc2aed9363e7524846bec79dfa.tar.bz2
aports-18933df139abc4bc2aed9363e7524846bec79dfa.tar.xz
testing/grub: enable on x86_64
currently gcc has an issue with no-pic on x86_84
Diffstat (limited to 'testing/grub/fix-gcc-no-pie-specs.patch')
-rw-r--r--testing/grub/fix-gcc-no-pie-specs.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/grub/fix-gcc-no-pie-specs.patch b/testing/grub/fix-gcc-no-pie-specs.patch
new file mode 100644
index 0000000000..b14c0be3cc
--- /dev/null
+++ b/testing/grub/fix-gcc-no-pie-specs.patch
@@ -0,0 +1,20 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -1092,7 +1092,7 @@
+ if test x"$grub_cv_target_cc_efiemu64_link_format" = xunknown; then
+ efiemu_excuse="no suitable link format for efiemu64 found"
+ else
+- EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format"
++ EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format -no-pie"
+ fi
+ fi
+ if test x"$enable_efiemu" = xyes && test x"$efiemu_excuse" != x ; then
+@@ -1188,7 +1188,7 @@
+ [# Need that, because some distributions ship compilers that include
+ # `-fPIE' and '-pie' in the default specs.
+ if [ x"$pie_possible" = xyes ]; then
+- TARGET_CFLAGS="$TARGET_CFLAGS -fno-PIE"
++ TARGET_CFLAGS="$TARGET_CFLAGS -no-pie"
+ fi
+ if [ x"$nopie_possible" = xyes ] && [ x"$pie_possible" = xyes ]; then
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -no-pie"