aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gsoap
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/gsoap
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/gsoap')
-rw-r--r--testing/gsoap/APKBUILD62
-rw-r--r--testing/gsoap/stdsoap2.c.diff11
-rw-r--r--testing/gsoap/stdsoap2.cpp.diff20
-rw-r--r--testing/gsoap/stdsoap2.h.diff11
4 files changed, 0 insertions, 104 deletions
diff --git a/testing/gsoap/APKBUILD b/testing/gsoap/APKBUILD
deleted file mode 100644
index 3730e768a9..0000000000
--- a/testing/gsoap/APKBUILD
+++ /dev/null
@@ -1,62 +0,0 @@
-# Contributor: <xmingske@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
-pkgname=gsoap
-pkgver=2.8.23
-pkgrel=0
-arch="all"
-pkgdesc='A cross-platform C and C++ SDK for SOAP/XML Web services'
-license='GPL-2 gSOAP'
-url='http://gsoap2.sourceforge.net'
-
-depends=''
-makedepends='autoconf automake bison flex zlib-dev openssl-dev'
-subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/project/gsoap2/gSOAP/${pkgname}_${pkgver}.zip
- stdsoap2.c.diff
- stdsoap2.cpp.diff
- stdsoap2.h.diff
-"
-
-gsopa_major='2.8'
-
-_builddir="$srcdir"/$pkgname-$gsopa_major
-
-prepare() {
- cd "${_builddir}"
- for f in $source; do
- case $f in
- *.diff) patch -p1 < "$srcdir"/$f
- esac
- done
-}
-
-build() {
- cd "${_builddir}"
- touch configure.ac aclocal.m4 configure Makefile.am Makefile.in
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --exec-prefix=/usr \
- --enable-ipv6 \
- || return 1
- make -j1 || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="9aa06f75cd3e3defee3e81cb9a2d1743 gsoap_2.8.23.zip
-24c9892ba231da9cff0fdfd834cebb71 stdsoap2.c.diff
-8f62eb5fbd92c850c86ca4e6900efe1d stdsoap2.cpp.diff
-b8a9439699427356b1e90d4cfc1af146 stdsoap2.h.diff"
-sha256sums="e1c30743f1c2cf40b2760568127e14af1b2a00c3026b2e5f0750e8c33d94c061 gsoap_2.8.23.zip
-ab0dea89ffb1b98d5e6c7d0a4975b9c9c022099729217b898a15934f360d88d0 stdsoap2.c.diff
-e0414a1127f9529dfb4b686b3721fd5aaedf46a8bd795b09cca24a1b66bd8872 stdsoap2.cpp.diff
-9f73f51791be1f149c1ef0db676832f1c0cad6837d14931666b3b18083f4b7e4 stdsoap2.h.diff"
-sha512sums="cc90aadfe09aa6406172c9ffa07696851ff594ca7c5b40819494badd8ce978d908d66de63a5831e7aec1bca18ee8b51ed02187057688a3b36eb0a21fe6e0f5a4 gsoap_2.8.23.zip
-116c0e1fd9d3c17ba4625934c7cd158084a9f9198a4ffae0036589d923b010e58143a8aea7804adf91683114f0bc99494f3ecc4139006b901e975ccb429e3543 stdsoap2.c.diff
-4d9b6f09407e3af95a8a2e282e5a379b5e313df21285beab69459a990aa035ee6e8fcba05b06e120f5f0e5b0e1f8499f8cdb4c41615f7cd5692fb875a88e46c8 stdsoap2.cpp.diff
-de271db85f4bfef8a01392c8aca864b16da4efe4acb1919827f7145202db32fbc8c872b225d865bbe98e144cc579c46cb419e041475b3127fc7d442680938a0a stdsoap2.h.diff"
diff --git a/testing/gsoap/stdsoap2.c.diff b/testing/gsoap/stdsoap2.c.diff
deleted file mode 100644
index 0d7b7bfec4..0000000000
--- a/testing/gsoap/stdsoap2.c.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- gsoap-2.8.orig/gsoap/stdsoap2.c
-+++ gsoap-2.8/gsoap/stdsoap2.c
-@@ -3963,7 +3963,7 @@
- { memcpy(inaddr, &iadd, sizeof(iadd));
- return SOAP_OK;
- }
--#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
-+#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) || defined(LINUX)
- if (gethostbyname_r(addr, &hostent, soap->buf, SOAP_BUFLEN, &host, &soap->errnum) < 0)
- host = NULL;
- #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
diff --git a/testing/gsoap/stdsoap2.cpp.diff b/testing/gsoap/stdsoap2.cpp.diff
deleted file mode 100644
index 66590b3a05..0000000000
--- a/testing/gsoap/stdsoap2.cpp.diff
+++ /dev/null
@@ -1,20 +0,0 @@
---- gsoap-2.8.orig/gsoap/stdsoap2.cpp
-+++ gsoap-2.8/gsoap/stdsoap2.cpp
-@@ -3963,7 +3963,7 @@
- { memcpy(inaddr, &iadd, sizeof(iadd));
- return SOAP_OK;
- }
--#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
-+#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) || defined(LINUX)
- if (gethostbyname_r(addr, &hostent, soap->buf, SOAP_BUFLEN, &host, &soap->errnum) < 0)
- host = NULL;
- #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
-@@ -17240,7 +17240,7 @@
- {
- #ifndef WIN32
- # ifdef HAVE_STRERROR_R
--# ifdef _GNU_SOURCE
-+# if defined (_GNU_SOURCE) && defined(__GLIBC__)
- return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
- # else
- strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
diff --git a/testing/gsoap/stdsoap2.h.diff b/testing/gsoap/stdsoap2.h.diff
deleted file mode 100644
index f21310a523..0000000000
--- a/testing/gsoap/stdsoap2.h.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- gsoap-2.8.orig/gsoap/stdsoap2.h
-+++ gsoap-2.8/gsoap/stdsoap2.h
-@@ -859,7 +859,7 @@
- # endif
- #elif defined(SOCKLEN_T)
- # define SOAP_SOCKLEN_T SOCKLEN_T
--#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE)
-+#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE) || defined (LINUX)
- # define SOAP_SOCKLEN_T socklen_t
- #elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS) || defined(HP_UX)
- # define SOAP_SOCKLEN_T int