aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gstreamermm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-26 17:12:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-26 17:12:42 +0000
commit41089764f6674e0f9e93802f637973b79a8bdeef (patch)
tree5207d0c883f64bcc16f05a3a4a6512d4a7299082 /testing/gstreamermm
parentc192b978fa520ce25cc5586d3a766719d253b69f (diff)
downloadaports-41089764f6674e0f9e93802f637973b79a8bdeef.tar.bz2
aports-41089764f6674e0f9e93802f637973b79a8bdeef.tar.xz
testing/gstreamermm: upgrade to 1.10.0
Diffstat (limited to 'testing/gstreamermm')
-rw-r--r--testing/gstreamermm/APKBUILD10
-rw-r--r--testing/gstreamermm/gst-audioclock.patch53
2 files changed, 4 insertions, 59 deletions
diff --git a/testing/gstreamermm/APKBUILD b/testing/gstreamermm/APKBUILD
index 0dc135c00c..6091f06e7c 100644
--- a/testing/gstreamermm/APKBUILD
+++ b/testing/gstreamermm/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gstreamermm
-pkgver=1.8.0
-pkgrel=1
+pkgver=1.10.0
+pkgrel=0
pkgdesc="C++ interface for GStreamer"
url="http://gstreamer.freedesktop.org/bindings/cplusplus.html"
arch="all"
license="LGPL"
makedepends="glibmm-dev gst-plugins-base-dev"
checkdepends="gtest-dev"
-options="!check"
+options="!check" #tests are broken
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/gstreamermm/${pkgver%.[0-9]*}/$pkgname-$pkgver.tar.xz
- gst-audioclock.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -32,5 +31,4 @@ check() {
cd "$builddir"
make check
}
-sha512sums="4d458c8a2efde683dabd00308ddde6fbf732788fb9282cb2eeab9f3a01dc9b4a03bfbbe9991cd50ef3092cec861034b3a34a6c5e364582dbfc6b1a0d5bb935fe gstreamermm-1.8.0.tar.xz
-6c0db61bbfe849b5829663b7caccb883bba698c89350003dba6a020b83a8491cafecff1c444d85e4f27c91f8106dfa503e02aed4c61a19e7aed3fdc2e62b6b74 gst-audioclock.patch"
+sha512sums="34eeb9eec5958c96acf7c7791eef80138e5d55fea6ddf1bf9ace6b1ec7f052da2abf04d87089e4c9ead51c631ef7afceaf9fceb946ec3d105da522187c69e429 gstreamermm-1.10.0.tar.xz"
diff --git a/testing/gstreamermm/gst-audioclock.patch b/testing/gstreamermm/gst-audioclock.patch
deleted file mode 100644
index 66d680150f..0000000000
--- a/testing/gstreamermm/gst-audioclock.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Marcin Kolny <marcin.kolny@gmail.com>
-Date: Sat, 10 Jun 2017 15:11:22 +0100
-Subject: Gst::AudioClock: auto generate some audioclock methods
-
-Those methods used to have object of GstClock type as a
-first argument, so had to be wrapped manually. It has been
-fixed inGStreamer (https://bugzilla.gnome.org/show_bug.cgi?id=756628)
-in version 1.12.0
-
-https://bugzilla.gnome.org/show_bug.cgi?id=783628
-
-Index: gstreamermm-1.8.0/gstreamer/gstreamermm/audioclock.cc
-===================================================================
---- gstreamermm-1.8.0.orig/gstreamer/gstreamermm/audioclock.cc
-+++ gstreamermm-1.8.0/gstreamer/gstreamermm/audioclock.cc
-@@ -2,6 +2,7 @@
-
-
- #include <glibmm.h>
-+#include <gst/gstversion.h>
-
- #include <gstreamermm/audioclock.h>
- #include <gstreamermm/private/audioclock_p.h>
-@@ -76,17 +77,29 @@ AudioClock::AudioClock(const Glib::ustri
-
- Gst::ClockTime AudioClock::adjust(Gst::ClockTime time)
- {
-+#if GST_VERSION_MAJOR == 1 && GST_VERSION_MINOR >= 12
-+ return ((Gst::ClockTime)(gst_audio_clock_adjust(gobj(), ((GstClockTime)(time)))));
-+#else
- return static_cast<Gst::ClockTime>(gst_audio_clock_adjust(GST_CLOCK_CAST(gobj()), static_cast<GstClockTime>(time)));
-+#endif
- }
-
- Gst::ClockTime AudioClock::get_time() const
- {
-+#if GST_VERSION_MAJOR == 1 && GST_VERSION_MINOR >= 12
-+ return ((Gst::ClockTime)(gst_audio_clock_get_time(const_cast<GstAudioClock*>(gobj()))));
-+#else
- return static_cast<Gst::ClockTime>(gst_audio_clock_get_time(GST_CLOCK_CAST(gobj())));
-+#endif
- }
-
- void AudioClock::invalidate()
- {
-+#if GST_VERSION_MAJOR == 1 && GST_VERSION_MINOR >= 12
-+ gst_audio_clock_invalidate(gobj());
-+#else
- gst_audio_clock_invalidate(GST_CLOCK_CAST(gobj()));
-+#endif
- }
-
- } //namespace Gst