aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gutenprint/gutenprint-O6.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-06 14:05:19 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-06 21:40:36 +0200
commita33d64800e845b5b341e38357d0e2792d40cf2b6 (patch)
treedada772677e0c4004623d5c705b489014bd568e6 /testing/gutenprint/gutenprint-O6.patch
parent834ac32b80a52a3bfe59e8c4e03c50ebd6552d13 (diff)
downloadaports-a33d64800e845b5b341e38357d0e2792d40cf2b6.tar.bz2
aports-a33d64800e845b5b341e38357d0e2792d40cf2b6.tar.xz
testing/gutenprint: new aport
Printer Drivers Package http://gimp-print.sourceforge.net/ fixes #4656
Diffstat (limited to 'testing/gutenprint/gutenprint-O6.patch')
-rw-r--r--testing/gutenprint/gutenprint-O6.patch281
1 files changed, 281 insertions, 0 deletions
diff --git a/testing/gutenprint/gutenprint-O6.patch b/testing/gutenprint/gutenprint-O6.patch
new file mode 100644
index 0000000000..0c1084b66d
--- /dev/null
+++ b/testing/gutenprint/gutenprint-O6.patch
@@ -0,0 +1,281 @@
+diff -up gutenprint-5.2.7/configure.ac.O6 gutenprint-5.2.7/configure.ac
+--- gutenprint-5.2.7/configure.ac.O6 2011-05-02 03:20:49.000000000 +0200
++++ gutenprint-5.2.7/configure.ac 2011-05-05 12:40:29.000000000 +0200
+@@ -625,27 +625,6 @@ AH_TEMPLATE(PKGMODULEDIR,, [Package modu
+ PKGMODULEDIR="${PACKAGE_LIB_DIR}/${GUTENPRINT_RELEASE_VERSION}/modules"
+ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
+
+-dnl Compiler flags
+-if test x$ac_compiler_gnu = "xyes"; then
+- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
+- if test x${USE_MAINTAINER_MODE} = xyes ; then
+- STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+- fi
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O6 -O3 -O2 -O1 -O])
+- fi
+-else
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O])
+- fi
+-fi
+-if test x$ENABLE_PROFILE = xyes ; then
+- STP_ADD_COMPILER_ARG([-pg])
+-fi
+ AC_SUBST(GNUCFLAGS)
+
+ AH_TEMPLATE([HAVE_GCC_ATTRIBUTES],
+diff -up gutenprint-5.2.7/configure.O6 gutenprint-5.2.7/configure
+--- gutenprint-5.2.7/configure.O6 2011-05-02 03:32:21.000000000 +0200
++++ gutenprint-5.2.7/configure 2011-05-05 12:52:09.000000000 +0200
+@@ -16589,246 +16589,6 @@ cat >>confdefs.h <<_ACEOF
+ #define PKGMODULEDIR "$PKGMODULEDIR"
+ _ACEOF
+
+-
+-if test x$ac_compiler_gnu = "xyes"; then
+-
+- for stp_ac_arg in -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 ; do
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
+-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- GNUCFLAGS="${stp_newCFLAGS}"
+-
+- done
+-
+- if test x${USE_MAINTAINER_MODE} = xyes ; then
+-
+- for stp_ac_arg in -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
+-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- GNUCFLAGS="${stp_newCFLAGS}"
+-
+- done
+-
+- fi
+- if test x$ENABLE_DEBUG = xyes ; then
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
+-$as_echo_n "checking if ${CC} supports -g... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${CFLAGS} -g"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- CFLAGS="${stp_newCFLAGS}"
+-
+- else
+-
+- for stp_ac_arg in -O6 -O3 -O2 -O1 -O ; do
+- stp_ac_save_CFLAGS="${CFLAGS}"
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
+-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${CFLAGS} ${stp_ac_arg}"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- CFLAGS="${stp_newCFLAGS}"
+-
+- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
+- done
+-
+- fi
+-else
+- if test x$ENABLE_DEBUG = xyes ; then
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
+-$as_echo_n "checking if ${CC} supports -g... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${CFLAGS} -g"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- CFLAGS="${stp_newCFLAGS}"
+-
+- else
+-
+- for stp_ac_arg in -O ; do
+- stp_ac_save_CFLAGS="${CFLAGS}"
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
+-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${CFLAGS} ${stp_ac_arg}"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- CFLAGS="${stp_newCFLAGS}"
+-
+- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
+- done
+-
+- fi
+-fi
+-if test x$ENABLE_PROFILE = xyes ; then
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -pg" >&5
+-$as_echo_n "checking if ${CC} supports -pg... " >&6; }
+- stp_acOLDCFLAGS="${CFLAGS}"
+- CFLAGS="${CFLAGS} -pg"
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; };
+- stp_newCFLAGS="$CFLAGS"
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; };
+- stp_newCFLAGS="$stp_acOLDCFLAGS"
+-fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$stp_acOLDCFLAGS"
+- CFLAGS="${stp_newCFLAGS}"
+-
+-fi
+-
+-
+-
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if $CC supports __attribute__ syntax" >&5
+ $as_echo_n "checking if $CC supports __attribute__ syntax... " >&6; }
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext