aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gx-go/APKBUILD
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-03-05 13:02:12 -0600
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-01 19:11:31 +0000
commita9bccb09bad16864922406dbe9286e05f7402574 (patch)
treeff4ad108bed2319ab0868d1b1ce047a25e0f5c9e /testing/gx-go/APKBUILD
parent0ebd74570127c670bfb45dab635c544dac4d5748 (diff)
downloadaports-a9bccb09bad16864922406dbe9286e05f7402574.tar.bz2
aports-a9bccb09bad16864922406dbe9286e05f7402574.tar.xz
testing/gx-go: new aport
https://github.com/whyrusleeping/gx-go A tool to use with the gx package manager for packages written in go
Diffstat (limited to 'testing/gx-go/APKBUILD')
-rw-r--r--testing/gx-go/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/testing/gx-go/APKBUILD b/testing/gx-go/APKBUILD
new file mode 100644
index 0000000000..236212e657
--- /dev/null
+++ b/testing/gx-go/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=gx-go
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="A tool to use with the gx package manager for packages written in go"
+url="https://github.com/whyrusleeping/gx-go"
+arch="all"
+license="MIT"
+options="!check" # Test suite issues
+makedepends="git glide go"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/$pkgname/archive/v$pkgver.tar.gz
+ glide.yaml
+ glide.lock
+ "
+builddir="$srcdir/src/github.com/whyrusleeping/$pkgname"
+
+prepare() {
+ export GOPATH="$srcdir"
+
+ mkdir -p $(dirname $builddir)
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+
+ cd "$builddir"
+ cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
+ glide install --skip-test
+
+ default_prepare
+}
+
+build() {
+ GOPATH="$srcdir" GOBIN="$GOPATH/bin" make
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 bin/gx-go "$pkgdir/usr/bin/gx-go"
+
+ cd "$builddir"
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}
+
+glide_init() {
+ abuild clean deps unpack prepare
+ cd "$builddir"
+ export GOPATH="$startdir"
+ rm -f glide.yaml glide.lock
+ glide init --non-interactive
+ glide update
+ cp glide.yaml glide.lock "$startdir"
+ cd "$startdir" && abuild checksum clean
+}
+
+sha512sums="3df8a99d257098afdf99ba6cbf58d50eab196f823ae53db48865a4f4962e38b84a66ffc99d5a342b43ff9891c8245252a77677b75c770d86f93ef1ad3c9e879f gx-go-1.9.0.tar.gz
+db824fce3e8094e2806c68b18ba5b8decae4cb62068113f6bc97f72de1224bd326b3342297739ee9b5a86bd4f7c9ec2f9b04aa3610cc95903dc1b3bfd7b0934f glide.yaml
+0a13f10b02099f2c60a8d1bbc83faf4552ae04358b4df99d431712704004030f3af31142ea81ed5f038e51ef6aeeeb3cf1946fd90e9d164af0d551ce0a0425d9 glide.lock"