aboutsummaryrefslogtreecommitdiffstats
path: root/testing/h1-cli
diff options
context:
space:
mode:
authorAdam Dobrawy <naczelnik@jawnosc.tk>2019-05-18 16:46:32 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-19 11:55:44 +0000
commit92c95b3d21d6b5c18aa207b7be1c2577e3a7bf3a (patch)
treeae4d706fce0bb4f186c0184ce5ee208a969ed412 /testing/h1-cli
parent130087fd8a036cf3521de07d849c559f496cd013 (diff)
downloadaports-92c95b3d21d6b5c18aa207b7be1c2577e3a7bf3a.tar.bz2
aports-92c95b3d21d6b5c18aa207b7be1c2577e3a7bf3a.tar.xz
testing/h1-cli: remove invalid check,fix redundant code
Diffstat (limited to 'testing/h1-cli')
-rw-r--r--testing/h1-cli/APKBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/testing/h1-cli/APKBUILD b/testing/h1-cli/APKBUILD
index 90ccc0ecda..4448ebe196 100644
--- a/testing/h1-cli/APKBUILD
+++ b/testing/h1-cli/APKBUILD
@@ -12,20 +12,13 @@ depends="openssh-client"
makedepends="nodejs npm"
subpackages="rbx-cli:rbx"
source="$pkgname-$pkgver.tar.gz::https://github.com/hyperonecom/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-options="!strip"
+options="!strip !check"
build() {
- cd "$builddir"
npm install
npm run-script build
}
-check() {
- [ "$($builddir/dist/$_pkgname-alpine --version)" == "$pkgver" ]
- [ "$($builddir/dist/rbx-alpine --version)" == "$pkgver" ]
-}
-
package() {
mkdir -p "$pkgdir"/usr/bin
cp "$builddir/dist/$_pkgname-alpine" "$pkgdir"/usr/bin/$_pkgname