aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handlebars/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-22 22:47:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-23 11:58:21 -0300
commit6d771da4d969148e6770767df8d06b9cdf1026ed (patch)
treef17195539b82b8b8ec8726f7c9344cb111ad9b9d /testing/handlebars/APKBUILD
parent3cc6ffed8ba27ee6cbdcf6841a7058692adf45e1 (diff)
downloadaports-6d771da4d969148e6770767df8d06b9cdf1026ed.tar.bz2
aports-6d771da4d969148e6770767df8d06b9cdf1026ed.tar.xz
testing/handlebars: upgrade to 0.7.1
Diffstat (limited to 'testing/handlebars/APKBUILD')
-rw-r--r--testing/handlebars/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/testing/handlebars/APKBUILD b/testing/handlebars/APKBUILD
index 79303a687f..ed156eb6a7 100644
--- a/testing/handlebars/APKBUILD
+++ b/testing/handlebars/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Rafael del Valle <rvalle@privaz.io>
pkgname=handlebars
_pkgname=handlebars.c
-pkgver=0.6.4
-pkgrel=2
+pkgver=0.7.1
+pkgrel=0
_mustachespec_ver="1.1.3"
_handlebarsspec_ver="4.0.5-p1"
pkgdesc="C implementation of handlebars.js"
@@ -16,14 +16,11 @@ subpackages="$pkgname-dev $pkgname-utils"
source="$_pkgname-$pkgver.tar.gz::https://github.com/jbboehr/$_pkgname/archive/v$pkgver.tar.gz
mustache-spec-$_mustachespec_ver.tar.gz::https://github.com/mustache/spec/archive/v$_mustachespec_ver.tar.gz
handlebars-spec-$_handlebarsspec_ver.tar.gz::https://github.com/jbboehr/handlebars-spec/archive/v$_handlebarsspec_ver.tar.gz
- fix-test-failure-on-ppc64le.patch
test_lmdb_cache.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- cd "$builddir"
-
mkdir -p spec
ln -sf "$srcdir"/spec-$_mustachespec_ver spec/mustache
ln -sf "$srcdir"/handlebars-spec-$_handlebarsspec_ver spec/handlebars
@@ -34,21 +31,18 @@ prepare() {
}
build() {
- cd "$builddir"
-
./configure \
--prefix=/usr \
- --disable-refcounting
+ --disable-refcounting \
+ --disable-static
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -59,8 +53,7 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="fae85ac30ce85b089c79c8b67cbf96cc94527d6b1ee2e83d05e638662c85b9bb1bd2aee06168dcd1ae2a15879f9f218dbecac012c25b583749d61f0921e0af16 handlebars.c-0.6.4.tar.gz
+sha512sums="14fb87bae07bddede988bbd53e2f3aeaafcff9148acbace71eb30afc2e74740191ef2bd1998fba1966e6d667d66abaf95133531e867dab02a61e70538343ddda handlebars.c-0.7.1.tar.gz
801a9cbf8a39080b183b20fbf327b420bcd6ed162bb58165dabafeb45fae277a9da506b6639ee7b955f6c206f0b8826d39588a43ffd86ab5ef4be6e9be2bc842 mustache-spec-1.1.3.tar.gz
81f0ff5ffc2d6b72465bdcbd2325d022faf73ec79586f3d8dfb07b7a6ec9147280872a82184b8d7ecdd8b22611b6b420c02ab437794bcd0aba67d2bf2082bc5d handlebars-spec-4.0.5-p1.tar.gz
-41a75d3e48d9eee2a404f41d5779d104895b72d4e8f9d00b207b468fc832ddc76fcd268fee3939cfb89f1dbba8149b39a7cef3b781c0f0da0b7abbbab55d3fec fix-test-failure-on-ppc64le.patch
6cdfae1356019c06ce993cba9c5091713e51f22b21f3572aaa2b2d4b1b18cf68f120f1fcb93822a118352e2885bd4c20635ea22aedb31a438e43dc40a6be581a test_lmdb_cache.patch"