aboutsummaryrefslogtreecommitdiffstats
path: root/testing/heirloom-doctools
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-06-20 12:32:41 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-06-20 12:32:51 +0200
commitf8605daab9db216ff9f4fcdcdd4f5024d6abf07e (patch)
treea6ac6df0530177c0731257743c280d1d70f4c3ca /testing/heirloom-doctools
parent3e8145eec8f3eff1a480aed8c1698d60b6d9d1df (diff)
downloadaports-f8605daab9db216ff9f4fcdcdd4f5024d6abf07e.tar.bz2
aports-f8605daab9db216ff9f4fcdcdd4f5024d6abf07e.tar.xz
testing/heirloom-doctools: don't supply mk.config
Diffstat (limited to 'testing/heirloom-doctools')
-rw-r--r--testing/heirloom-doctools/APKBUILD44
-rw-r--r--testing/heirloom-doctools/mk.config121
2 files changed, 27 insertions, 138 deletions
diff --git a/testing/heirloom-doctools/APKBUILD b/testing/heirloom-doctools/APKBUILD
index 78b64bbde7..3fc499a422 100644
--- a/testing/heirloom-doctools/APKBUILD
+++ b/testing/heirloom-doctools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=heirloom-doctools
pkgver=160308
-pkgrel=1
+pkgrel=2
pkgdesc="The Heirloom Documentation Tools"
url="http://n-t-roff.github.io/heirloom/doctools.html"
arch="all"
@@ -12,29 +12,39 @@ depends_dev=""
makedepends="flex bison"
install=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/n-t-roff/${pkgname}/archive/${pkgver}.tar.gz
- mk.config"
+source="$pkgname-$pkgver.tar.gz::https://github.com/n-t-roff/${pkgname}/archive/${pkgver}.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- # Copy our configuration file to the build directory.
- cp -f "$srcdir"/mk.config "$_builddir"/ || return 1
-}
+_makeargs="
+ CC="${CC:-gcc}" \
+ CCC="${CCX:-g++}" \
+ EUC=-DEUC \
+ STRIP=true \
+ RANLIB=ranlib \
+ INSTALL=install \
+ BINDIR=/usr/bin \
+ MANDIR=/usr/share/man \
+ LIBDIR=/usr/lib/$pkgname \
+ REFDIR=/usr/lib/$pkgname/reftools \
+ MACDIR=/usr/share/$pkgname/tmac \
+ FNTDIR=/usr/share/$pkgname/font \
+ TABDIR=/usr/share/$pkgname/nterm \
+ HYPDIR=/usr/share/$pkgname/hyphen \
+ PUBDIR=/usr/share/$pkgname/pub \
+ PSTDIR=/usr/share/$pkgname/font/devpost/postscript
+"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
# Unfortunately parallel build isn't supported.
- make -j1 -C "$_builddir" || return 1
+ make -j1 $_makeargs -C "$builddir" || return 1
}
package() {
# Unfortunately parallel install isn't supported.
- make -j1 ROOT="$pkgdir" \
- -C "$_builddir" install || return 1
+ make -j1 ROOT="$pkgdir" $_makeargs \
+ -C "$builddir" install || return 1
}
-md5sums="f9759a099fca6b3021da33b94b1f37a9 heirloom-doctools-160308.tar.gz
-a9c5f8bc84e6d42a7c3e6264889cddf3 mk.config"
-sha256sums="d54e22e89acfddae4cd7a1fb583ca5fce097ba4c91c7b32f634944f137af175b heirloom-doctools-160308.tar.gz
-1442e3e1392dcdef475a660a995937fd2322646f56bf32267b89240eb4124b6b mk.config"
-sha512sums="46a5b2969a807abeb4a45eb63db918c903fe02226edddccabc4eabc7e6ad77dd1c0cf633fe55981f16907cb96f3a94a769383966d2f5f5dcde276734f7ad00d7 heirloom-doctools-160308.tar.gz
-34ba8463be83fb4dd0dde0215ddb82c12e68a7ee5cfbe5c68783f72203c066b10145787960b904f5b07b4219f62240129fb9004bdbc971d4a4c54705c85d3d4c mk.config"
+md5sums="f9759a099fca6b3021da33b94b1f37a9 heirloom-doctools-160308.tar.gz"
+sha256sums="d54e22e89acfddae4cd7a1fb583ca5fce097ba4c91c7b32f634944f137af175b heirloom-doctools-160308.tar.gz"
+sha512sums="46a5b2969a807abeb4a45eb63db918c903fe02226edddccabc4eabc7e6ad77dd1c0cf633fe55981f16907cb96f3a94a769383966d2f5f5dcde276734f7ad00d7 heirloom-doctools-160308.tar.gz"
diff --git a/testing/heirloom-doctools/mk.config b/testing/heirloom-doctools/mk.config
deleted file mode 100644
index 9a826aec37..0000000000
--- a/testing/heirloom-doctools/mk.config
+++ /dev/null
@@ -1,121 +0,0 @@
-#
-# A BSD-compatible install command.
-#
-INSTALL=/usr/bin/install
-
-#
-# Packaging prefix.
-#
-PREFIX=/usr
-
-#
-# Where to place binaries.
-#
-BINDIR=$(PREFIX)/bin/
-
-#
-# Where to place libraries.
-#
-LIBDIR=$(PREFIX)/lib
-
-#
-# Where to place ASCII charts and the like.
-#
-PUBDIR=$(PREFIX)/share/doctools
-
-#
-# Where to place manual pages.
-#
-MANDIR=$(PREFIX)/share/man
-
-#
-# Where to place the troff macro packages.
-#
-MACDIR=$(PUBDIR)/tmac
-
-#
-# Where to place the troff font files.
-#
-FNTDIR=$(PUBDIR)/font
-
-#
-# Where to place PostScript helper files.
-#
-PSTDIR=$(PUBDIR)/postscript
-
-#
-# Where to place the nroff terminal description files.
-#
-TABDIR=$(PUBDIR)/nterm
-
-#
-# Where to place troff hyphenation files.
-#
-HYPDIR=$(PUBDIR)/hyphen
-
-#
-# Where to place files belonging to the "refer" utility.
-#
-REFDIR=$(PUBDIR)/reftools
-
-#
-# Define this if you want troff and nroff to be able to process
-# locale-specific (8-bit) characters. It requires appropriate support
-# from the C library, so it does not work e.g. with diet libc.
-#
-EUC=-DEUC
-
-#
-# Binaries are stripped with this command after installation.
-#
-STRIP=strip
-
-#
-# The C compiler.
-#
-CC?=cc
-
-#
-# The C++ compiler.
-#
-CCC?=c++
-
-#
-# Compiler flags.
-#
-#CFLAGS=-O
-
-#
-# C preprocessor flags.
-#
-# Use -D_GNU_SOURCE for Linux with GNU libc.
-# Use -D_INCLUDE__STDC_A1_SOURCE for HP-UX.
-#
-CPPFLAGS+=-D_GNU_SOURCE
-
-#
-# Warning flags for the compiler.
-#
-#WARN=
-
-#
-# Linker flags.
-#
-#LDFLAGS=
-
-#
-# Additional libraries to link with.
-#
-LIBS=
-
-#
-# A Bourne-compatible shell.
-#
-SHELL=/bin/sh
-
-#
-# Run ranlib if it is in the current path. This should take care
-# of most situations. On Mac OS X, you need to uncomment "ranlib -c".
-#
-RANLIB=(hash ranlib) >/dev/null 2>&1 || exit 0; ranlib
-#RANLIB=ranlib -c