aboutsummaryrefslogtreecommitdiffstats
path: root/testing/heplify/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2020-03-13 10:46:32 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2020-03-13 10:47:27 +0000
commit035e88883c4f2fad1931fe969b53b376de3055a7 (patch)
treea54ef9f3e6277416907584f29a7122dc467d54ca /testing/heplify/APKBUILD
parent52be8680f3c7844aae3e448c985c34993550881a (diff)
downloadaports-035e88883c4f2fad1931fe969b53b376de3055a7.tar.bz2
aports-035e88883c4f2fad1931fe969b53b376de3055a7.tar.xz
testing/heplify: new aport
HEP Capture Agent. This is part of the HOMER 7.x suite
Diffstat (limited to 'testing/heplify/APKBUILD')
-rw-r--r--testing/heplify/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/heplify/APKBUILD b/testing/heplify/APKBUILD
new file mode 100644
index 0000000000..80f7b976b2
--- /dev/null
+++ b/testing/heplify/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=heplify
+pkgver=1.56
+pkgrel=0
+pkgdesc="Multi-Protocol Go HEP Capture Agent made Simple"
+url="http://sipcapture.io"
+arch="all"
+license="AGPL-3.0-or-later"
+makedepends="go libpcap-dev linux-headers"
+subpackages="$pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/heplify/archive/$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ "
+
+build() {
+ make all
+}
+
+check() {
+ make test
+}
+
+package() {
+ install -D -m755 heplify "$pkgdir"/usr/bin/$pkgname
+ install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="d9eb0dec39c446a7a163b69221b32182733dc7bc1477e29e8e74bffddf961a1416c98d44a792cc9a3aae936002c7eb384e3128d96937736746829bf219f49555 heplify-1.56.tar.gz
+0981666e3a36e48573fa62913f400665a9396ec620fb325ccda40b97acff45f11e533c41f9899d587483c13f2c164e1ecf650de0b61f63924c1cd80b72c1cca6 heplify.initd
+da89419e17acd25cca30af13cca1a9278283cbe258de30da747fafa41bd567e3337992a8f1773cdc2eb64848ec35c30a132f81a10dada5d4dae431ef29d391f0 heplify.confd"