aboutsummaryrefslogtreecommitdiffstats
path: root/testing/heplify
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2020-03-13 10:46:32 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2020-03-13 10:47:27 +0000
commit035e88883c4f2fad1931fe969b53b376de3055a7 (patch)
treea54ef9f3e6277416907584f29a7122dc467d54ca /testing/heplify
parent52be8680f3c7844aae3e448c985c34993550881a (diff)
downloadaports-035e88883c4f2fad1931fe969b53b376de3055a7.tar.bz2
aports-035e88883c4f2fad1931fe969b53b376de3055a7.tar.xz
testing/heplify: new aport
HEP Capture Agent. This is part of the HOMER 7.x suite
Diffstat (limited to 'testing/heplify')
-rw-r--r--testing/heplify/APKBUILD32
-rw-r--r--testing/heplify/heplify.confd20
-rw-r--r--testing/heplify/heplify.initd13
3 files changed, 65 insertions, 0 deletions
diff --git a/testing/heplify/APKBUILD b/testing/heplify/APKBUILD
new file mode 100644
index 0000000000..80f7b976b2
--- /dev/null
+++ b/testing/heplify/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=heplify
+pkgver=1.56
+pkgrel=0
+pkgdesc="Multi-Protocol Go HEP Capture Agent made Simple"
+url="http://sipcapture.io"
+arch="all"
+license="AGPL-3.0-or-later"
+makedepends="go libpcap-dev linux-headers"
+subpackages="$pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/heplify/archive/$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ "
+
+build() {
+ make all
+}
+
+check() {
+ make test
+}
+
+package() {
+ install -D -m755 heplify "$pkgdir"/usr/bin/$pkgname
+ install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="d9eb0dec39c446a7a163b69221b32182733dc7bc1477e29e8e74bffddf961a1416c98d44a792cc9a3aae936002c7eb384e3128d96937736746829bf219f49555 heplify-1.56.tar.gz
+0981666e3a36e48573fa62913f400665a9396ec620fb325ccda40b97acff45f11e533c41f9899d587483c13f2c164e1ecf650de0b61f63924c1cd80b72c1cca6 heplify.initd
+da89419e17acd25cca30af13cca1a9278283cbe258de30da747fafa41bd567e3337992a8f1773cdc2eb64848ec35c30a132f81a10dada5d4dae431ef29d391f0 heplify.confd"
diff --git a/testing/heplify/heplify.confd b/testing/heplify/heplify.confd
new file mode 100644
index 0000000000..5a716c0196
--- /dev/null
+++ b/testing/heplify/heplify.confd
@@ -0,0 +1,20 @@
+# Command line options supported by heplify
+# -i Listen on interface (default "any")
+# -nt Network types are [udp, tcp, tls] (default "udp")
+# -t Capture types are [pcap, af_packet] (default "pcap")
+# -m Capture modes [SIP, SIPDNS, SIPLOG, SIPRTCP] (default "SIPRTCP")
+# -pr Portrange to capture SIP (default "5060-5090")
+# -hs HEP UDP server address (default "127.0.0.1:9060")
+# -hi HEP Node ID (default 2002)
+# -di Discard uninteresting packets by string
+# -dim Discard uninteresting SIP packets by CSeq [OPTIONS,NOTIFY]
+# -fi Filter interesting packets by string
+# -rf Read PCAP file
+# -rs Use original timestamps when reading PCAP file
+# -wf Path to write pcap file
+# -zf Enable pcap compression
+# -e Log to stderr and disable syslog/file output
+# -d Enable certain debug selectors [fragment,layer,payload,rtp,rtcp,sdp]
+
+# Default
+# CMD_OPTS="-i lo"
diff --git a/testing/heplify/heplify.initd b/testing/heplify/heplify.initd
new file mode 100644
index 0000000000..c906f8c349
--- /dev/null
+++ b/testing/heplify/heplify.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+
+description="Multi-Protocol Go HEP Capture Agent"
+supervisor=supervise-daemon
+command=/usr/bin/heplify
+command_args=${CMD_OPTS:="-i lo"}
+pidfile="/run/homer/${RC_SVCNAME}.pid"
+
+depend() {
+ need net
+ after firewall
+}
+