aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hexchat
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-05 14:12:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-05 14:13:49 +0000
commitfc13a4932c72d888e9044e1a51932ec708c4a204 (patch)
tree74797d07b6ff9b37ac7f77c3cec4a8573d4155c4 /testing/hexchat
parent6f22508d6b73f6e04b80f4b1d507d2892226f10f (diff)
downloadaports-fc13a4932c72d888e9044e1a51932ec708c4a204.tar.bz2
aports-fc13a4932c72d888e9044e1a51932ec708c4a204.tar.xz
testing/hexchat: new aport
A popular and easy to use graphical IRC (chat) client http://www.hexchat.org
Diffstat (limited to 'testing/hexchat')
-rw-r--r--testing/hexchat/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/testing/hexchat/APKBUILD b/testing/hexchat/APKBUILD
new file mode 100644
index 0000000000..130a45e02b
--- /dev/null
+++ b/testing/hexchat/APKBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hexchat
+pkgver=2.9.5
+pkgrel=0
+pkgdesc="A popular and easy to use graphical IRC (chat) client"
+url="http://www.hexchat.org"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="gtk+2.0-dev openssl-dev dbus-glib-dev perl-dev
+ libsexy-dev python-dev libnotify-dev libproxy-dev
+ bash libtool autoconf automake"
+install=""
+subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
+source="http://dl.hexchat.org/hexchat/hexchat-$pkgver.tar.xz"
+
+_builddir="$srcdir"/hexchat-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-openssl \
+ --enable-dbus \
+ --disable-textfe \
+ --disable-perl \
+ --enable-python \
+ --enable-ipv6 \
+ --enable-shm \
+ --enable-spell=libsexy || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/hexchat/plugins/*.la || return 1
+ # not worth a -dev pkg
+ rm -r "$pkgdir"/usr/include
+}
+
+_python() {
+ pkgdesc="Python plugin for hexchat"
+ mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
+ mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
+ "$subpkgdir"/usr/lib/hexchat/plugins
+}
+
+md5sums="e9b678e439890f9842a94f657ce7ae3f hexchat-2.9.5.tar.xz"
+sha256sums="11dfd0fbfb88d8dbb38f631fab8a7dffbb179f7f7dafe316953ed6f513ac623d hexchat-2.9.5.tar.xz"
+sha512sums="67eee124b6d0b690d3a43b921826af11730f995de5a697bbcac0d9dca13d44df6e33f3f2273ff1f7f86cc7dca34c091e70c4c481de49a83688522648e3252b9e hexchat-2.9.5.tar.xz"