aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hexer/APKBUILD
diff options
context:
space:
mode:
authorBradley J Chambers <brad.chambers@gmail.com>2017-08-02 10:43:23 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 08:26:37 +0000
commite235329df8a1b9b4d025cbafb622346961ae9312 (patch)
treee73ed5014323a77fed125af0b1284da2a6087ee5 /testing/hexer/APKBUILD
parent477c10a9e35c2726c09eda96fdc0387c7658172d (diff)
downloadaports-e235329df8a1b9b4d025cbafb622346961ae9312.tar.bz2
aports-e235329df8a1b9b4d025cbafb622346961ae9312.tar.xz
testing/hexer: new aport
https://github.com/hobu/hexer LAS and OGR hexagonal density and boundary surface generation.
Diffstat (limited to 'testing/hexer/APKBUILD')
-rw-r--r--testing/hexer/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/hexer/APKBUILD b/testing/hexer/APKBUILD
new file mode 100644
index 0000000000..ba71db9d31
--- /dev/null
+++ b/testing/hexer/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
+# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
+pkgname=hexer
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="LAS and OGR hexagonal density and boundary surface generation"
+url="https://github.com/hobu/hexer"
+arch="all"
+license="LGPL2+"
+options="!check"
+depends="gdal"
+makedepends="cmake gdal-dev"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hobu/$pkgname/archive/$pkgver.tar.gz
+ 10-missing-includes.patch
+ 20-compile-test-for-execinfo.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4db94af7fe0a2cc3cd26202c4ec88fadd88408c92d14e11ac117af51ee267aa87cd82aa18b29867f318d272f644be60a826e7fb3c72908baba4124499f39579c hexer-1.4.0.tar.gz
+971434a5c7b817296ecf7fa44222c0b7db909bef0c8bf130daef6b9db0ee68bab7aa8ef59aae1e6eda1daa801e4fbe2a5a88f22083d4c885de5a1e05310f9a0a 10-missing-includes.patch
+9fd03681856e42ac5747b98a45542d24289bcd687c377035382835692df4ba23773bc9601d1b5b2c4e0a345aa8dac8b0c80a95a19f318b27b82a8bbfc87509cc 20-compile-test-for-execinfo.patch"