aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hfst
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-02 06:53:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-02 12:42:44 -0300
commit9e211382c75694b725f282e958ab9d5ed93e226a (patch)
tree3f4efba81e4823b611eaafbb58290a2e2213254b /testing/hfst
parentba7729a771d32daea3d70e434aaa91ca5a8ec1f5 (diff)
downloadaports-9e211382c75694b725f282e958ab9d5ed93e226a.tar.bz2
aports-9e211382c75694b725f282e958ab9d5ed93e226a.tar.xz
testing/hfst: upgrade to 3.13.0
Diffstat (limited to 'testing/hfst')
-rw-r--r--testing/hfst/APKBUILD50
1 files changed, 17 insertions, 33 deletions
diff --git a/testing/hfst/APKBUILD b/testing/hfst/APKBUILD
index 03feba521e..d16bef5346 100644
--- a/testing/hfst/APKBUILD
+++ b/testing/hfst/APKBUILD
@@ -2,29 +2,18 @@
# Contributor: Frankie Robertson <frankie@robertson.name>
# Maintainer:
pkgname=hfst
-pkgver=3.9.1
+pkgver=3.13.0
pkgrel=0
pkgdesc="Helsinki Finite-State Transducer Technology toolkit"
url="http://www.ling.helsinki.fi/kieliteknologia/tutkimus/$pkgname/"
-arch="" # Fails to build
-license="LGPL-3.0"
-depends=""
-depends_dev=""
-makedepends="$depends_dev python2 bison python2-dev swig"
-install=""
-subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py"
-source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+arch="all"
+license="LGPL-3.0-or-later"
+makedepends="python3 bison python3-dev swig"
+subpackages="$pkgname-dev $pkgname-doc py3-$pkgname:py3 $pkgname-libs"
+source="https://github.com/hfst/hfst/releases/download/v$pkgver/hfst-$pkgver.tar.gz
missing_unistd_include.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- default_prepare || return 1
- update_config_sub || return 1
-}
-
build() {
- cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,30 +25,25 @@ build() {
--without-foma \
--enable-lexc \
--enable-all-tools \
- || return 1
- make -j1 || return 1
+ --disable-static \
+ PYTHON=python3
+ make -j1
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
- cd python || return 1
- python2 setup.py install \
- --prefix=/usr --root="$pkgdir" || return 1
+ cd python
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-py() {
- pkgdesc="$pkgdesc (python bindings)"
- depends="python2"
+py3() {
+ pkgdesc="$pkgdesc (python3 bindings)"
+ depends="python3"
mkdir -p "$subpkgdir"/usr/lib/
- cp -r "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib/
+ cp -r "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
-md5sums="3d7a54b6ce67d180545d599b7d9fa7c9 hfst-3.9.1.tar.gz
-4aef69581668aa22cf1e93cbd6493030 missing_unistd_include.patch"
-sha256sums="fa55eab71d86ffebe75ed28476d76cb6bcde51dbc73064a8ef1db7112d2985ec hfst-3.9.1.tar.gz
-158d633416a482308f420c6d9e3c8648f96238fc7209d70055e629a0ff978b80 missing_unistd_include.patch"
-sha512sums="2d0d4acd132cb4a41c4a1f259b2556ac3ce352158ad88ea2312d056e1942dd2d5d0968e86ee62e00aca36fb757371657d0466132ae3576b70962f5313357df44 hfst-3.9.1.tar.gz
+sha512sums="9070d23577528ef562cce7229faf15206cbcf615b38500deedc6b5c58be4a0bdb14165f8bb3da644a2f264860ea0e8f2bc663e46284bc55c7b03a45c07845296 hfst-3.13.0.tar.gz
0bfc63709dbefaaa4084bf78d169283a58ab4ee586e800446f5d92ee179d4c84959802f54e72ffa5366c49a2a30883deb54c562c9dcace21662d5cbdd06789d6 missing_unistd_include.patch"