aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hhpc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-20 19:17:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-20 19:18:33 +0000
commitc1abc6379217f1543652e2b4651eb61e88801246 (patch)
treeb9dd69e8233b7965aeaf6fa0ee0977fd381af7c9 /testing/hhpc
parente789a67a0eab80d6bdf97b348c7c67e7071439d1 (diff)
downloadaports-c1abc6379217f1543652e2b4651eb61e88801246.tar.bz2
aports-c1abc6379217f1543652e2b4651eb61e88801246.tar.xz
testing/hhpc: new aport
An utility to automatically hide the mouse pointer after a specified delay of inactivity https://github.com/aktau/hhpc
Diffstat (limited to 'testing/hhpc')
-rw-r--r--testing/hhpc/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/hhpc/APKBUILD b/testing/hhpc/APKBUILD
new file mode 100644
index 0000000000..aa14f8683d
--- /dev/null
+++ b/testing/hhpc/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor:
+# Maintainer:
+pkgname=hhpc
+pkgver=0.3.2
+pkgrel=0
+pkgdesc="An utility to automatically hide the mouse pointer after a specified delay of inactivity"
+url="https://github.com/aktau/hhpc"
+arch="all"
+license="3-clause BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="hhpc-$pkgver.tar.gz::https://github.com/7heo/hhpc/archive/v$pkgver.tar.gz"
+_builddir="$srcdir"/hhpc-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="2d579207ce5d6b3fbbfa4b81109ffaa3 hhpc-0.3.2.tar.gz"
+sha256sums="7701e20143133317d0746b6f723bdd9bff92fb7c4bd9af745e632444dbbc3afa hhpc-0.3.2.tar.gz"
+sha512sums="c07a054c1826cff530f27c047e52bc982bfe057fa5c92dfd3af42750b4aa8369c614529b62e701c5f9199749659f47e3c56bcbc68b14a0b86b35c9a031d80417 hhpc-0.3.2.tar.gz"