aboutsummaryrefslogtreecommitdiffstats
path: root/testing/homer-ui
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-05-16 14:14:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-05-16 14:15:02 +0000
commit2971ba1409c346d30922be1c4f9059ebe6be071d (patch)
tree14c738d119554f9a091fb903c660a7af862e561f /testing/homer-ui
parent7562de815872c72801773bd605ffdd1894e79dd1 (diff)
downloadaports-2971ba1409c346d30922be1c4f9059ebe6be071d.tar.bz2
aports-2971ba1409c346d30922be1c4f9059ebe6be071d.tar.xz
testing/homer-ui: needs php-ctype
Diffstat (limited to 'testing/homer-ui')
-rw-r--r--testing/homer-ui/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/testing/homer-ui/APKBUILD b/testing/homer-ui/APKBUILD
index 40ea7fdae1..e25713a6bb 100644
--- a/testing/homer-ui/APKBUILD
+++ b/testing/homer-ui/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=homer-ui
pkgver=5.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="HOMER User-Interface"
url="https://github.com/sipcapture/homer-ui"
arch="noarch"
-license="GPL"
-depends="homer-api php5-mysql php5-gd php5-json"
+license="AGPL3"
+depends="homer-api php5-ctype php5-mysql php5-gd php5-json"
depends_dev=
makedepends="$depends_dev"
install=
@@ -16,23 +16,23 @@ pkggroups="www-data"
source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/homer-ui/archive/v${pkgver}-ui.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver-ui
+builddir="$srcdir"/$pkgname-$pkgver-ui
prepare() {
- cd "$_builddir"
+ cd "$builddir"
# apply patches here
return 0
}
build() {
- cd "$_builddir"
+ cd "$builddir"
return 0
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/share/webapps/homer-ui "$pkgdir"/etc/homer
- mv "$_builddir"/* "$pkgdir"/usr/share/webapps/homer-ui
+ mv "$builddir"/* "$pkgdir"/usr/share/webapps/homer-ui
chown -R :www-data "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard
chmod -R 664 "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard
mv "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard "$pkgdir"/etc/homer/ || return 1