aboutsummaryrefslogtreecommitdiffstats
path: root/testing/howard-bc/APKBUILD
diff options
context:
space:
mode:
authorGavin Howard <yzena.tech@gmail.com>2019-04-04 16:24:07 -0600
committerprspkt <prspkt@protonmail.com>2019-04-18 00:54:39 +0300
commitac008cd90ef8fdf446ab21432fa01cd3f84fc8da (patch)
tree1c5292ee4585023ed0e91ae99a670b79a7749e29 /testing/howard-bc/APKBUILD
parentb5b15cf9969466a51f1f1b6fd83fc0684c8060f3 (diff)
downloadaports-ac008cd90ef8fdf446ab21432fa01cd3f84fc8da.tar.bz2
aports-ac008cd90ef8fdf446ab21432fa01cd3f84fc8da.tar.xz
testing/howard-bc: bump to 1.2.6
This version removes a few subtle, but rare bugs. It also makes all shell scripts completely POSIX-compatible by removing the use of `local`. It also adds locales, but since Alpine does not have a replacement for gencat, I can't enable that support. The `-N` option given to configure.sh turns off locale support.
Diffstat (limited to 'testing/howard-bc/APKBUILD')
-rw-r--r--testing/howard-bc/APKBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/testing/howard-bc/APKBUILD b/testing/howard-bc/APKBUILD
index caf468f606..4d172524d1 100644
--- a/testing/howard-bc/APKBUILD
+++ b/testing/howard-bc/APKBUILD
@@ -2,19 +2,19 @@
# Maintainer: Gavin D. Howard <yzena.tech@gmail.com>
pkgname=howard-bc
_pkgname=bc
-subpackages="$pkgname-doc"
-pkgver=1.1.4
+pkgver=1.2.6
pkgrel=0
pkgdesc="POSIX bc with GNU extensions"
url="https://github.com/gavinhoward/bc"
arch="all"
license="BSD-2-Clause"
+subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.xz::https://github.com/gavinhoward/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- PREFIX=/usr DESTDIR="$pkgdir" EXECSUFFIX=-howard ./configure.sh -G
+ PREFIX=/usr DESTDIR="$pkgdir" EXECSUFFIX=-howard ./configure.sh -GN
make
}
@@ -23,20 +23,12 @@ check() {
make test
}
-doc() {
- # Man pages
- mkdir -p "$subpkgdir"/usr/share/man
- mv "$pkgdir"/usr/share/man/man* "$subpkgdir"/usr/share/man/
- gzip "$subpkgdir"/usr/share/man/man*/*
-
- # Doc files
- install -Dm644 "$builddir"/LICENSE.md \
- "$subpkgdir"/usr/share/doc/$pkgname/LICENSE.md
-}
-
package() {
cd "$builddir"
make install
+
+ install -Dm644 LICENSE.md \
+ "$pkgdir"/usr/share/doc/$pkgname/LICENSE.md
}
-sha512sums="fa67325cc3cb5df7513e6d0ae74d3476d7d9e87722db2f24d0cf0781622f02ec99e6ab27d3e2d57866830dd18dc43eb3c52d460be6c6ec0260ce2bad7765d7aa howard-bc-1.1.4.tar.xz"
+sha512sums="c8ff2ac542413bf594a00ea9a8a9e4cd24e48081839a4e11546a08551a73b4f460391edf7f3aa3f5143db5c4e7bc1448ff7cd1104599cfa2fb44fba79c5b24fc howard-bc-1.2.6.tar.xz"