aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hstr
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-24 21:11:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-24 21:06:41 +0200
commite600734d0530006c6aa4883014d1619b79991bff (patch)
tree40a69b82aecbe09d1c9a7ac6214e08b610a3a59f /testing/hstr
parent04ef5a240ec30fe748acfbe1ccf3c8dc1c29b3ec (diff)
downloadaports-e600734d0530006c6aa4883014d1619b79991bff.tar.bz2
aports-e600734d0530006c6aa4883014d1619b79991bff.tar.xz
testing/hstr: new aport
https://github.com/dvorka/hstr Bash and ZSH shell history suggest box Resolves #9027 (https://bugs.alpinelinux.org/issues/9027)
Diffstat (limited to 'testing/hstr')
-rw-r--r--testing/hstr/APKBUILD44
-rw-r--r--testing/hstr/hstr-symlink.patch10
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/hstr/APKBUILD b/testing/hstr/APKBUILD
new file mode 100644
index 0000000000..c208dc0fe4
--- /dev/null
+++ b/testing/hstr/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=hstr
+pkgver=1.25
+pkgrel=0
+pkgdesc="Bash and ZSH shell history suggest box"
+url="https://github.com/dvorka/hstr"
+arch="all"
+license="Apache-2.0"
+makedepends="autoconf automake libtool ncurses-dev readline-dev"
+options="!check" # no *automated* tests to run
+subpackages="$pkgname-doc"
+source="https://github.com/dvorka/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz
+ hstr-symlink.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ sed -i "s|<ncursesw/curses.h>|<curses.h>|" \
+ src/include/hstr_curses.h src/hstr.c
+
+ cd "$builddir"/dist
+ sh 1-dist.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="83c6250b1627bf185a572a7278a23f1e779d8f926f62fe341644f0d26b4f9daac8d904a5fe5af63e963a2ec15b7d98ee229bd5f812ee0d167bd2a12ee2e57467 hstr-1.25.tar.gz
+eca1780a23f75d4987eea078b952648fa8db2b03e0dcf90cb46f7251d7096f83a95b17e9ca344cded72aeade77de355fd34d31157ea2d2d581eba3a957f745d0 hstr-symlink.patch"
diff --git a/testing/hstr/hstr-symlink.patch b/testing/hstr/hstr-symlink.patch
new file mode 100644
index 0000000000..011dd98a7e
--- /dev/null
+++ b/testing/hstr/hstr-symlink.patch
@@ -0,0 +1,10 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -34,6 +34,6 @@
+
+ # create hh > hstr hard link on installation
+ install-exec-hook:
+- ln $(DESTDIR)$(bindir)/hh$(EXEEXT) $(DESTDIR)$(bindir)/hstr$(EXEEXT)
++ ln -s hh$(EXEEXT) $(DESTDIR)$(bindir)/hstr$(EXEEXT)
+
+ hh_LDADD = $(NCURSES_LIBS)