aboutsummaryrefslogtreecommitdiffstats
path: root/testing/http-parser/0005-makefile-fix-install-rule-dependency.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-03-27 23:01:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-30 08:26:05 +0000
commite379b72e209d55a68ac76a614c358e7bb8ea23f1 (patch)
treeac52f0611b80b1b9e3bf4bbcda6318b72b862ca3 /testing/http-parser/0005-makefile-fix-install-rule-dependency.patch
parent83c66b420d4c2bd4b8a93e1fe243161ce8efc22d (diff)
downloadaports-e379b72e209d55a68ac76a614c358e7bb8ea23f1.tar.bz2
aports-e379b72e209d55a68ac76a614c358e7bb8ea23f1.tar.xz
testing/http-parser: new abuild
https://github.com/nodejs/http-parser HTTP request/response parser for C
Diffstat (limited to 'testing/http-parser/0005-makefile-fix-install-rule-dependency.patch')
-rw-r--r--testing/http-parser/0005-makefile-fix-install-rule-dependency.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/http-parser/0005-makefile-fix-install-rule-dependency.patch b/testing/http-parser/0005-makefile-fix-install-rule-dependency.patch
new file mode 100644
index 0000000000..da96637306
--- /dev/null
+++ b/testing/http-parser/0005-makefile-fix-install-rule-dependency.patch
@@ -0,0 +1,33 @@
+From b67bfbe6a07529dd82e2ee83b6848d017e6e422f Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@hasufell.de>
+Date: Mon, 2 Nov 2015 16:51:28 +0100
+Subject: [PATCH 5/5] makefile: fix install rule dependency
+
+Otherwise the install rule will recompile the library, no matter
+if it has already been compiled.
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae16f08..df0b59f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -122,12 +122,12 @@ parsertrace_g: http_parser_g.o contrib/parsertrace.c
+ tags: http_parser.c http_parser.h test.c
+ ctags $^
+
+-install: library
++install: $(SONAME)
+ $(INSTALL) -D http_parser.h "$(DESTDIR)$(INCLUDEDIR)/http_parser.h"
+ $(INSTALL) -D $(SONAME) "$(DESTDIR)$(LIBDIR)/$(SONAME)"
+ ln -s $(SONAME) "$(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)"
+
+-install-strip: library
++install-strip: $(SONAME)
+ $(INSTALL) -D http_parser.h "$(DESTDIR)$(INCLUDEDIR)/http_parser.h"
+ $(INSTALL) -D -s $(SONAME) "$(DESTDIR)$(LIBDIR)/$(SONAME)"
+ ln -s $(SONAME) "$(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)"
+--
+2.6.1
+