aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hub
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-02 19:25:07 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-02 19:28:09 +0000
commit723d1744587d636ce59f5a48432a29af645f4ed4 (patch)
tree072d4b591dc3a9ae85d16f8fa104e01369c88b5d /testing/hub
parentcee1999d0a9e9f4156396b27e92f099641592ba4 (diff)
downloadaports-723d1744587d636ce59f5a48432a29af645f4ed4.tar.bz2
aports-723d1744587d636ce59f5a48432a29af645f4ed4.tar.xz
testing/hub: add check
Diffstat (limited to 'testing/hub')
-rw-r--r--testing/hub/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
index c0a0ccbf8a..00bbd88ae5 100644
--- a/testing/hub/APKBUILD
+++ b/testing/hub/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=hub
pkgver=2.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Extends git with extra features for GitHub"
url="http://hub.github.com/"
arch="all"
@@ -31,6 +31,11 @@ build() {
./script/build
}
+check() {
+ cd "$builddir"
+ go test ./...
+}
+
package() {
cd "$builddir"
install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"